Top 10 SQL Compare Tips. Watch now.

SQL Compare Static Data Issue

devesharmadevesharma Posts: 4 New member
edited July 6, 2020 10:17AM in SQL Compare
Hey Guys!

Using Azure SQL DB and I had this weird issue while committing static data. The same row appears in both SQL Source Control and in linked database as well which when committing raises an error "no changes; nothing to commit". Due to this, while generating deployment scripts, it removes the same row from table and adds it again. I did all sort of options, un-link the DB from source control, removed transient copies, re-cloned the repo but haven't been able to fix this.

For reference : Source Control version is 6.1.8.7584
SQL Data Compare version is 13.0.5.5219
SQL Compare version is 13.3.2.5875

Any leads would be greatly appreciated!

Best Answer

  • DanCDanC Posts: 190 Gold 1
    edited July 7, 2020 10:50AM Accepted Answer
    Hi @devesharma

    Sorry to hear you're experiencing this issue!

    I can see you're on quite old versions of the product, would you be able to upgrade to the following versions and see if the error persists?

    Source Control version is 6.1.8.7584 > 7.1.28.10996

    SQL Data Compare version is 13.0.5.5219 > 14.2.18.16317

    SQL Compare version is 13.3.2.5875 > 14.2.18.16317

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

Answers

  • devesharmadevesharma Posts: 4 New member
    Hey @DanC

    Thanks for your suggestion and sorry for the Long absence on my part. So finally we have decided to go for an upgrade and see if it fixes things on our end. In order to revert, we'll require SQLDataCompare exe with version string 13.0.5.5219. I searched through the old versions but could not find it. Can you please provide us a download link for the same ?

    Also, we have a paid version of SQL Toolbelt version 13, will a major upgrade say from 6 to 7 for source control be a part of the current license or do we have to acquire a new license ?

    Appreciate your help on this :)
  • Hi @devesharma

    That's okay! forgive my confusion, but how come you wish to revert to the old version?

    I got the customer team to look into your license and I believe you should be supported to upgrade to the latest versions of the products!

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

  • devesharmadevesharma Posts: 4 New member
    Hey @DanC ,

    After getting a good look into the system, we figured out the exact component we had to upgrade. Managed to fix the static data issue by bumping up DLM Automation 2 suite to the final version 2.1.3.2175 and Source control to 6.3.7.8574.

    Static Data is no more an issue for us now.

    Thanks for your valuable feedback :-D
  • Hey @devesharma

    Ah brilliant, pleased to hear you managed to solve the issue!

    If you require any more help don't hesitate to get in contact with us on the support team!

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

Sign In or Register to comment.