Problem installing base monitor v10.1

CraigPHCraigPH Posts: 7 New member
I am attempting to install SQL Monitor 10.1 in our development environment - we are currently running 8.0.4

During the install I get an error popup saying that the SQL Monitor Base Monitor service cannot be installed, and that I should check that I have sufficient privileges to install system services.  The account I am using is both a local and domain administrator, and I have also tried running it "as administrator" and in every case, it fails to install that service.  

Worse, the service was marked for deletion by the failed install, and so now even the previous version is not working.  Fortunately this is our development environment, but I would still like to resolve this issue - the whole point is to test the installation for production.

Any suggestions for a resolution would be greatly appreciated.  

Thanks
Tagged:

Answers

  • CraigPHCraigPH Posts: 7 New member
    Some additional information....

    Event log has an error each time I tried that has a unhandled exception FileNotFound.

     

    Application: RedGate.SqlMonitor.Engine.Alerting.Base.Service.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an unhandled exception.

    Exception Info: System.IO.FileNotFoundException

       at System.Configuration.TypeUtil.GetTypeWithReflectionPermission(System.Configuration.Internal.IInternalConfigHost, System.String, Boolean)

       at System.Configuration.MgmtConfigurationRecord.CreateSectionFactory(System.Configuration.FactoryRecord)

       at System.Configuration.BaseConfigurationRecord.FindAndEnsureFactoryRecord(System.String, Boolean ByRef)


  • Are you able to completely uninstall the previous version, assuming the other service was still present, and try just installing rather than upgrading (though in effect its the same process).


    Have you visited our Help Centre?
  • CraigPHCraigPH Posts: 7 New member
    I completely uninstalled the previous version and the install failed again, this time the message was "Unable to start the service" and to make sure I am authorized to start system services.  My account is a local and domain admin on that server, so authorization should not be an issue.


  • Jessica RJessica R Posts: 1,239 Rose Gold 4
    So sorry for the long delay @CraigPH! We've just realized this has gone by without reply.

    Are you still running into this issue?

    There is likely an older file that isn't getting cleared out when you uninstall/reinstall. Can you please uninstall again, delete all files in c:\Program Files\Red Gate\SQL Monitor\BaseMonitor and then reinstall?

    Hope that helps but please let us know if not!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • CraigPHCraigPH Posts: 7 New member
    Unfortunately, no... we tried that back in June and I just tried it again now, and I get the same error saying that it cannot start the service, and to make sure I am authorized, etc.

    I believe we are scheduled to refresh the server (this is our DEV environment) from a copy of production sometime soon, so I was planning to try it again after that occurs.  It's totally possible that someone did something on the server that is causing the issue.  Once it's been refreshed, it will be an exact duplicate of production. 

    Will let you know if we still have the problem after the refresh.

    thanks
  • CraigPHCraigPH Posts: 7 New member
    Hello...  I tried the installation on a fresh copy of production and it still fails.  I also tried running the executable that makes up the Monitor service directly, and I get the following...  not sure if any of this is useful:

    2020-08-28 19:38:47,134 [    1] INFO  RedGate.SqlMonitor.Common.Logging.LogManager - Logging configured from file 'C:\Program Files\Red Gate\SQL Monitor\BaseMonitor\RedGate.SqlMonitor.Engine.Alerting.Base.Service.logging.json'
    2020-08-28 19:38:47,437 [    1] FATAL RedGate.SqlMonitor.Engine.Alerting.Base.Service.Program - Unhandled exception
    System.Configuration.ConfigurationErrorsException: An error occurred creating the configuration section handler for version: Could not load file or assembly 'RedGate.Response.Common.Utilities, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified. (C:\ProgramData\Red Gate\SQL Monitor\RedGate.SqlMonitor.Engine.Alerting.Base.Service.exe.settings.config line 5)
       at System.Configuration.BaseConfigurationRecord.FindAndEnsureFactoryRecord(String configKey, Boolean& isRootDeclaredHere)
       at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission)
       at System.Configuration.BaseConfigurationRecord.GetSection(String configKey)
       at System.Configuration.Configuration.GetSection(String sectionName)
       at RedGate.SqlMonitor.Engine.Monitoring.Core.LogRetrieval.ConfigurationFiles.GetAlertingServiceSettingsConfig()
       at RedGate.SqlMonitor.Engine.Alerting.Base.Service.Program.ConfigureContainer(ContainerBuilder builder, CommandLineOptions commandLineOptions)
       at RedGate.SqlMonitor.Engine.Alerting.Base.Service.Program.<>c__DisplayClass3_0.<CreateHostBuilder>b__0(ContainerBuilder builder)
       at Autofac.Extensions.DependencyInjection.AutofacServiceProviderFactory.CreateBuilder(IServiceCollection services)
       at Microsoft.Extensions.Hosting.Internal.ServiceFactoryAdapter`1.CreateBuilder(IServiceCollection services)
       at Microsoft.Extensions.Hosting.HostBuilder.CreateServiceProvider()
       at Microsoft.Extensions.Hosting.HostBuilder.Build()
       at RedGate.SqlMonitor.Engine.Alerting.Base.Service.Program.Main(String[] args)
    Inner exception:
       System.IO.FileNotFoundException: Could not load file or assembly 'RedGate.Response.Common.Utilities, Culture=neutral, PublicKeyToken=null'. The system cannot find the file specified.
          at System.Configuration.TypeUtil.GetType(IInternalConfigHost host, String typeString, Boolean throwOnError)
          at System.Configuration.MgmtConfigurationRecord.CreateSectionFactory(FactoryRecord factoryRecord)
          at System.Configuration.BaseConfigurationRecord.FindAndEnsureFactoryRecord(String configKey, Boolean& isRootDeclaredHere)
    End of inner exception:
    2020-08-28 19:38:47,469 [    2] INFO  RedGate.SqlMonitor.Common.Logging.LogManager - Application ended
  • Jessica RJessica R Posts: 1,239 Rose Gold 4
    Thanks Craig!

    I'm not totally sure what's causing this yet, but the log file is helpful.

    It's odd as it's mentioning a file called "RedGate.Response.Common.Utilities" but there isn't an assembly with that name in the install folder (I believe it may have been changed to RedGate.Monitor.Common.Utilities in later versions).

    Can you please open that config file, C:\ProgramData\Red Gate\SQL Monitor\RedGate.SqlMonitor.Engine.Alerting.Base.Service.exe.settings.config, and send across what you have in the listed "section names" e.g.:

    <configuration>
      <configSections>
        <section name="threadPool" type="RedGate.SqlMonitor.Common.Utilities.ConfigurationElements.ThreadPoolSection, RedGate.SqlMonitor.Common.Utilities"/>
        <section name="version" type="RedGate.SqlMonitor.Common.Utilities.ConfigurationElements.VersionSection, RedGate.SqlMonitor.Common.Utilities"/>
        <section name="networkSettings" type="RedGate.SqlMonitor.Common.Networking.Configuration.NetworkSettingsSection, RedGate.SqlMonitor.Common.Networking"/>
        <section name="repositorySettings" type="RedGate.SqlMonitor.Common.Persistence.ConfigurationElements.RepositorySettingsSection, RedGate.SqlMonitor.Common.Persistence"/>
        <section name="collectionSettings" type="RedGate.SqlMonitor.Common.Persistence.ConfigurationElements.CollectionSettingsSection, RedGate.SqlMonitor.Common.Persistence"/>
        <section name="featureUsageSettings" type="RedGate.SqlMonitor.Common.Utilities.ConfigurationElements.FeatureUsageSettingsSection, RedGate.SqlMonitor.Common.Utilities"/>
        <section name="debug" type="RedGate.SqlMonitor.Common.Persistence.ConfigurationElements.DebugSettingsSection, RedGate.SqlMonitor.Common.Persistence"/>
      </configSections>


    Can we also check what version number is listed there, e.g.  

     <version number="1" versionstring="10.2.1.31696"/>

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • CraigPHCraigPH Posts: 7 New member
    I apologize for the long delay, I got pulled into a project and this issue sort of slipped through the cracks again.  

    <configuration>
      <configSections>
        <section name="threadPool" type="RedGate.Response.Common.Utilities.ConfigurationElements.ThreadPoolSection, RedGate.Response.Common.Utilities"/>
        <section name="version" type="RedGate.Response.Common.Utilities.ConfigurationElements.VersionSection, RedGate.Response.Common.Utilities"/>
        <section name="networkSettings" type="RedGate.Response.Common.Networking.Configuration.NetworkSettingsSection, RedGate.Response.Common.Networking"/>
        <section name="repositorySettings" type="RedGate.Response.Common.Persistence.ConfigurationElements.RepositorySettingsSection, RedGate.Response.Common.Persistence"/>
        <section name="collectionSettings" type="RedGate.Response.Common.Persistence.ConfigurationElements.CollectionSettingsSection, RedGate.Response.Common.Persistence"/>
        <section name="featureUsageSettings" type="RedGate.Response.Common.Utilities.ConfigurationElements.FeatureUsageSettingsSection, RedGate.Response.Common.Utilities"/>
        <section name="debug" type="RedGate.Response.Common.Persistence.ConfigurationElements.DebugSettingsSection, RedGate.Response.Common.Persistence"/>
      </configSections>
      <debug fakeSchemaUpgrade="false"/>
      <version number="1" versionstring="8.0.4.12548"/>
      <threadPool minThreads="" maxThreads=""/>
      <networkSettings portNum="7399"/>

    On a side note, I tried completely uninstalling SQL Monitor (base and web) and tried installing version 11 and I still get the same error.




Sign In or Register to comment.