SQL Monitor 11.1 is now available. Learn more.

Adding back an instance previously removed from cluster

EmilianoEmiliano Posts: 3 New member
Hi everyone,
we recently removed an instance from an always on availability group (removing the server from the cluster nodes).
The instance seemed to be correctly removed from SQL Monitor as it stop showing either in the "Global Dashboard" pane and in the "monitored server" config menu, but when I tried to put it back (this time as a standalone instance) SQL Monitor thrown an "Invaild Class' exception when it tries to detect Sql Server (the query via WMI shows green flag instead).
After that the server (but not the sql instance) is showing as "monitoring connected" in monitored servers config menu, while, for example, the instance is showing as still part of the availability group in the "Alert Inbox"  pane (and elsewhere in the appliacation) and cannot be further monitored (old monitoring data still present).
Does anyone hit this scenario before?
Any possible clue as how to fix it?
Thanks
Tagged:

Answers

  • Russell DRussell D Posts: 1,325 Diamond 5
    It's fairly common that removing a node from a cluster doesn't clean out the mscluster namespaces, so we try to query them and thats why you end up with that exception as they no longer exist.

    If removing the cluster from Monitor then re-adding it doesn't work, you can rebuild the cluster namespace in WMI but I'd recommend logging a Support ticket for that.
    Have you visited our Help Centre?
  • EmilianoEmiliano Posts: 3 New member
    Hi Russel
    Yes, we tried to re-add the cluster (keeping the monitoring data!) with no luck, node still showed as part of the cluster in "Analysis" pane (no monitoring data).
    It seems like SQL Monitor does not update cluster info correctly....
    We also opened a support ticket
  • EmilianoEmiliano Posts: 3 New member
    Just to add some more info...
    I've removed the cluster and added the standalone node.
    This is what I get:

    Root\MSCluster namespace in WMI correctly shows the remaining 2 nodes and not the evicted one:


    Might it be something related to data still not being purged?
Sign In or Register to comment.