SQL Prompt Object Intellisense no longer working

Wayne_SWayne_S Posts: 3 New member
Version: 10.1.7.15015
SSMS: 15.0.18330.0

Enable Suggestion checked

In Options:
Show code suggestions is checked
Show tooltips for: objects and parameters is checked.
Show object definitions is checked

Essentially I clicked Restore Defaults.

It started occurring, nothing had changed, no updated version. Just stopped working. I have restarted SSMS and that doesn't help.
Tagged:

Answers

  • Jessica RJessica R Posts: 1,196 Rose Gold 4
    Hi @Wayne_S,

    Sorry to hear you're running into an issue!

    Can I just confirm if the suggestions box doesn't come up at all? Or does it come up but not suggest any of your objects (just snippets)?

    Can you please go to SQL Prompt>Options>Suggestions>Connections and make sure that it's still set to load for your database?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Wayne_SWayne_S Posts: 3 New member
    Hi Jessica,

    Load Suggestions for linked server/synonyms are checked. The only one not checked is referenced databases.

    The suggestions box are not appearing.

    What I did eventually do is save a Tab history database, uninstall everything and remove folders. Reinstalled, copied over my Tab History folder and everything seems to be working again.

    I now have another annoying issue, but I think that has something to do with my formatting. It keeps tabbing in every time I hit the enter key. Will find that one too.

    SELECT blah
    FROM blahblah a
           join blahblha on d=a
                             join happyA on b = a
                                                  join sdfgsdf

    Just keeps going in and in for no reason, also never did that before.

    Thanks for the help, at least the objects are coming up again.

    Wayne
  • Jessica RJessica R Posts: 1,196 Rose Gold 4
    Hi @Wayne_S,

    I'm so glad to hear that reinstalling got things working- thanks for sharing that!

    Ah I'm not able to reproduce that behavior with the tabbing, but please let us know if you're not able to track down the cause.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Wayne_SWayne_S Posts: 3 New member
    Hi J,

    I did manage to track down the issue with the tabs. In SSMS Options>Text Editor>All Languages>Tabs

    None the option boxes were selected. Nothing at all, which I find very strange. Simply selected None and Keep tabs. Now everything seems to be working with that.

    One thing I have noticed in SQL Prompt, when I open a new query window, create a new table and Refresh  Suggestions it only allows me to see the new table suggestions when I'm busy typing on a line.
    If I type

    Select * from newtable.

    The newtable is underlined in red as if it's not refreshed, or shows as does exist. If I then close the query window and open a new window, all works fine. Very strange.

    Wayne
  • Jessica RJessica R Posts: 1,196 Rose Gold 4

    Hi @Wayne_S,

    Thanks for sharing those details!

    Hm, the red underline comes from SSMS' native Intellisense so it seems that's taking some time to refresh. 

    Note that it is in beta, but there is a SQL Prompt experimental feature to automatically refresh Intellisense (under SQL Prompt>Options>Labs>Experimental features) which may help.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.