Command Line Sync Failure

Hello, 
I'm trying to sync multiple databases using SQL Compare 14.2 on the command line. I'm using SQL Source Control as the source for my database using the head of the master branch as the revision. The destination database is an empty database running on SQL server 2019 in a Docker container. However, every time I use the /sync flag on the command line the process fails. I spent some time debugging it and the problem seems to occur when creating procedures that are dependent on Views. The SQL Server stored procedure: sp_refreshview keeps throwing the error. I tried various command options to fix the issue such as checking for object existence, ignoring constraints, and ignoring checks. Error still happens. At this time I'm out of ideas. I tried copying the deployment script into a new query window in SSMS and the errors kept occurring. If anyone has any ideas on how to solve this problem I would really appreciate it  

Best Answer

  • DanCDanC Posts: 110 Silver 3
    Accepted Answer
    For the benefit of others, the solution here was to remove the historic migration scripts from the "Custom Scripts" folder in the repository

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

Answers

Sign In or Register to comment.