What are the challenges you face when working across database platforms? Take the survey
Options

Issue with post deployment schema check and DateTime2 column with static data

Hi!

When I try to deploy a table with a DateTime2 column, everything works as expected (using Azure DevOps tasks). If I add deploying static data into this table, the post deployment schema check fails caused by the data in the DateTime2 column. It looks like it could be an issue with the precision, as Data Compare shows the diff on this line (script folder compared with database). I tried almost every possible combination (DateTime2(7), DateTime2(0), DateTime2), without any success.

Is this a known issue in static data deployment and can this be fixed please as it's not our goal to disable post deployment schema checks

Answers

  • Options
    Hi Zoner,
    Do you need to synch the DateTime2 column? You can exclude it from the comparison by adding it to ExcludeColumnsFromDataSync in the project settings e.g:
    <ExcludeColumnsFromDataSync>Table=[dbo].[your-table-name].[your-column-mane]</ExcludeColumnsFromDataSync>

    You'll have to edit the project settings manually as there is no UI in the VS extension of editing static data columns or alternatively you can use the SSMS extension which has a Data tab where you can edit the columns.

    If that does not work for you, please contact our support so that we can get more information and  investigate further.

    Regards,
    Maya
  • Options
    ZonerZoner Posts: 2 New member
    Hi MayaMalakova

    As this could be a workaround for values which are automatically generated upon insertion, it is not the case for all other columns with business values inside.

    So I guess the only way is to contact support to get this fixed, right?

    Regards,
    Zoner
  • Options
    MayaMalakovaMayaMalakova Posts: 14 Bronze 1
    edited February 20, 2020 12:06PM
    Yes, please contact our support so they can get the details from you and investigate further. https://productsupport.red-gate.com
Sign In or Register to comment.