What are the challenges you face when working across database platforms? Take the survey
Options

SmartAssembly 6.8.0.121 : How do I fix the error "The server is not operational"

AFoulkesAFoulkes Posts: 2 New member
edited February 18, 2020 2:36PM in SmartAssembly
Good afternoon,

I am trying to move an installation of SmartAssembly 6.8 onto a new developer machine.
It looks like it has installed without any issues, it starts ok and I get the dialogue with the Activate and continue buttons ok it.
The machine I am installing SmartAssembly on doesn't have an internet connection, so I have been looking at the instructions here https://documentation.red-gate.com/sa6/getting-started/licensing/activating

If I click the Activate button to enter the serial number I get the following in a dialog box:

The server is not operational.

I have the option to send / save the error report, but that won't save either.

If I click continue and then try to activate from inside the app I get the same error message as above.
If I click the debug button I get a little more information:

System.Runtime.InteropServices.COMException was unhandled
Message: An unhandled exception of type 'System.Runtime.InteropServices.COMException' occurred in SmartAssembly.exe
Additional information: The server is not operational.

Specs are as follows:

OS: Windows 10 (64bit)
Memory: 4Gb
Disk Space: 50Gb free.

Apps:
Visual Studio 2013
MSSQL 2014
.NET Framework 4.5.x and 4.6.1

I have also tried installing as a normal user and an administrator, and I get the same error.

I am clearly missing something obvious, so any help would be gratefully received.

Thanks

Adam
Tagged:

Best Answer

Answers

  • Options
    Hi, 

    Thanks for your post. 

    Have you tried a Manual Activation? If you haven't, try the steps here: https://productsupport.red-gate.com/hc/en-us/articles/360004919994-Manual-Activation

    Kind regards

    Robyn Edwards | Redgate Software
    Have you visited our Help Center?
  • Options
    AFoulkesAFoulkes Posts: 2 New member
    Hi Robyn,

    Thanks for the reply and apologies for the delay in getting back to you.
    Unfortunately the steps in the link you have supplied haven't worked.

    When I try to connect to the status.html page I get the can't reach the page message.  I've tried it with both localhost, and my machines IP address, both of these with and without the firewall turned off just in case that made any difference.

    There doesn't seem to be anything in the event viewer relating to Smart Assembly either.  If it helps any when I get the error about the server is not operational I have the option to save the error file, if I click that button the app stops responding.

    Thanks for your help with this.

    Adam
Sign In or Register to comment.