Stored Procedure Autocomplete

nmg196nmg196 Posts: 8
edited June 11, 2009 10:14AM in SQL Prompt Previous Versions
How do you force a stored procedure autocomplete window to come up? If I start typing the name of a stored procedure in a Query window, nothing happens. If I press Ctrl-Space to force the autocomplete window to appear, the stored procedure icon is ghosted out and disabled (even though it's perfectly valid to call a stored procedure from a Query window - obviously)

Is this a bug or a am I doing something stupid? I've put everything on the default settings but it's still not working. It seems it geninely doesn't support SP names within the query window unless you're within an ALTER PROCEDURE block and type EXEC first (which is unnecessary).




  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Nick,

    SQl Prompt 3.9 does work as you need it to. You can start typing a stored procedure name and have candidate stored procedure names appear in the candidate list without the need to type ALTER... or EXEC.

    The only exception I know of is if you are creating a dynamic SQL string -- in that case no candidates should appear.
  • OK, this is REALLY weird! :

    I restarted SSMS and it started working in a new Query window when I typed "Get" (which many of my procedures start with). Then I looked at the about box for SQL Prompt and then closed it. I immediately typed the exact same thing ("Get") and no intellisense appears! Bang! It seems that once you've looked at the about box, much of the prompting is disabled! However if you then open a NEW query window, it works fine in the NEW window only. The existing window remains 'prompt-less'. It's only opening the About box that seems to cause this problem. If you go into anything else like Options or Check for Updates, it's fine.

    Please try this yourself and let me know if you see the same thing? I can reproduce this every time.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Sorry, this does not happen to me. Maybe it would be worth checking the log by selecting the "show log" item in the SQL Prompt menu and see if there is anything of interest in there.
  • I'm still getting this problem and it's really annoying. Stored procedures simply don't appear. Have you had any other reports of this?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    I don't know of ever seeing exactly the same problem. Have you though atbout trying the prompt 4.0 beta and seeing if it behaves the same way?
  • I've just updated to 4 and it seems to still have the same problem. It won't suggest stored procedure names unless I type "EXEC" first, but this worked fine in an older revision of version 3.
Sign In or Register to comment.