What are the challenges you face when working across database platforms? Take the survey
Options

SCA toolbar - Always reports "Could not connect to server"

When using the SCA toolbar within Visual Studio I am constantly having issues with connection. The server name is correct and configured to allow remote connections.
When Configuring the connection and clicking "Test Connection" I get a message stating "Test connection succeeded".
Once I OK this dialog the SCA toolbar tries to connect and "Fails" Always reporting and error.
I can Deploy successfully by going to Build > Deploy but even after this has succeeded I still get an error in the SCA window.
Version 4.2.20023.15120
Tagged:

Answers

  • Options
    Hi WillC,

    This sounds strange. Would you please contact our support so we can gather more details and investigate - https://productsupport.red-gate.com

    Cheers,
    Maya 
  • Options
    NigelHNigelH Posts: 4 Bronze 1
    This morning I have encountered the same problem, even though it has worked fine in the past. Was a solution found?

    Thanks,
    Nigel
  • Options
    WillCWillC Posts: 7 Bronze 1
    Nigel, for me to fix this I had to modify the project file, it's actually the "Default Connection string" that throws the error that is used for the Shadow Database. (even though it sounds like it's the target connection)

    The Key in the proj file is "<DefaultConnectionString>" The Datasource property wasn't pointing to an existing database.
  • Options
    nharris18nharris18 Posts: 7 New member
    Thanks for the reply, Will.

    Fortunately, just after posting I realised my own stupidity - I had switched to using a local shadow database  (to avoid leaving shadow databases scattered around) and my local server was shut down.

    That said, it is seriously confusing to have the connection dialog tell you that connection to the target is fine but then to say it can't connect without specifying what it can't connect to. An opportunity to improve the product, Redgate?
Sign In or Register to comment.