TLS/SSH Error Upon Installing SQL Clone Agent

behibberdbehibberd Posts: 5 Bronze 1
edited January 28, 2020 11:21PM in SQL Clone
One of our developers recently tried to install the SQL Clone Agent on his development machine, and he received the following error: "The request was aborted: Could not create SSL/TLS secure channel."

I believe the situation is as follows.  He had a previous installation of the clone agent on his machine, which he uninstalled.  We then rebuilt the clone server, and he tried to download and install a new agent.  This is when the error occurred.

After much troubleshooting, I think we found the problem.  Even though he uninstalled the older version of the clone agent, the uninstall appears to have left its connection certificate behind.  We removed the old connection certificate manually, and then the new installation proceeded without error.

The whole process looked like the following:
  1. Ensure that the clone agent is uninstalled from the development machine.
  2. Open PowerShell as an administrator.
  3. Type certlm.msc and press <Enter>.
  4. Browse to "Certificates - Local Computer" -> "Personal" -> "Certificates".
  5. Right-click the "SQL Clone Agent" certificate and delete it.
  6. Browse to the clone server and download a new agent installer.
  7. Launch the agent installer and follow its prompts.
Sign In or Register to comment.