'Unsupported database version 4' after downgrade from v10 to v9.5

Gareth99Gareth99 Posts: 1 New member
edited January 3, 2020 10:37AM in SQL Prompt
I received the error 'Unsupported database version 4' when I open SSMS (2014, version 12.0). I think it's because I did the following:

  Had a license for SQL Prompt 9
  Followed the prompts to upgrade to SQL Prompt 10
  Got a message that the trial had expired
  Uninstalled SQL Prompt 10 and re-installed v9.5.8 (using SQLDeveloperBundle.exe from 02/07/19)

How can I stop the error being reported every time I open SSMS?

Thanks

Comments

  • Gareth99Gareth99 Posts: 1 New member

    Thanks for getting in touch.  I'm sorry to hear that you're having problems with SQL Prompt.

    To stop this message appearing you can either delete your tab history file (%LOCALAPPDATA%\Red Gate\SQL Prompt
    9\SavedTabs.db
    ) but be warned you will lose your tab history.

    Alternatively, you can try upgrading to SQL Prompt v9.5.22 which should fix the issue, please use the following download link:
    https://download.red-gate.com/checkforupdates/SQLPrompt/SQLPrompt_9.5.22.12050.exe

    If you have any questions, just let me know and I'll be happy to help.

    Kind Regards,

    Sarah
    Customer Support Team
  • Gareth99Gareth99 Posts: 1 New member

    Thanks for getting in touch.  I'm sorry to hear that you're having problems with SQL Prompt.

    To stop this message appearing you can either delete your tab history file (%LOCALAPPDATA%\Red Gate\SQL Prompt
    9\SavedTabs.db
    ) but be warned you will lose your tab history.

    Alternatively, you can try upgrading to SQL Prompt v9.5.22 which should fix the issue, please use the following download link:
    https://download.red-gate.com/checkforupdates/SQLPrompt/SQLPrompt_9.5.22.12050.exe

    If you have any questions, just let me know and I'll be happy to help.

    Kind Regards,

    Sarah
    Customer Support Team
Sign In or Register to comment.