Having UI troubles linking to source control

stefanovuerichstefanovuerich Posts: 2 New member
edited November 18, 2019 2:23PM in SQL Source Control
I'm havins some troubles linking the database to the source control.

As you can see, rows are not fitted...

I tried to update graphic drivers but nothing has improved.

It happends on Windows 10, SSMS v18.4, SQL Source Control 7.0.41.9770.



Any suggestion?

Best Regards

Stefano
Tagged:

Answers

  • Hi there,

    So sorry for this issue you're running into!

    Can I please check what resolution you have set? If you change the scaling to 100%, does the problem remain?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • I'm using 3860x2160(recommended), with scaling 250%(recommended).
    If I scale to 100% having same issues.
  • Jessica RJessica R Posts: 1,288 Rose Gold 4
    Thank you @stefanovuerich !

    I'm afraid that some parts of the SQL Source Control UI still use Windows Forms code which does not deal well with 4K/High DPI, unfortunately. :/

    As mentioned here though, we have plans in 2020 to include a standalone SQL Source Control client to our portfolio, which will leverage more modern GUI components that should behave a lot better. 

    Very sorry for these issues in the meantime!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • TUellnerTUellner Posts: 48 Bronze 4
    Adding my voice to this as well. I cannot add a database to source control because of the same issue.
    FYI: This same problem exists across multiple tools. This is just my most current one that I've run across. The SQL Prompt team seems to have fixed this issue.
Sign In or Register to comment.