Profiler 2.0 hangs when taking snapshot or stopping

dgibbdgibb Posts: 5
Hi,

A problem seems to have developed with my installation of Profiler 2.0. When I try to profile our ASP.NET web app (this has worked in the past), I cannot get any results. When clicking the Snapshot button, profiler just hangs forever with the "Please Wait... taking snapshot" window up. The same thing happens if I close the browser window - it hangs on "stopping profiler". If I use the Stop button from within Profiler, it stops profiling but does not show any results.

This is mysterious because I had all this working a few weeks earlier. I used the tool extensively and it was fantastic. In the interim, something seems to have broken.

I'm not getting any error messages such as "The web application has not loaded the .NET Framework" - I've already troubleshooted that one by reconfiguring the virtual directory to 1.1 using aspnet_regiis. I've checked that nothing else is listening on port 8087. I've tried re-registering shdocvw.dll.

Any clues?

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Thanks for your post to the forum. There isn't a lot of information here to say the Profiler had suddenly stopped working. The Stop button in version 2.0 has changed from version 1.3 -- it merely stops the profiler and will not return results.

    If the problem is because of 1.0 and 1.1 Frameworks installed on the same computer, then you would get the 'application has not loaded the .net Framework' error message.

    When you attempt to get a snapshot, do any error messages or warnings appear in the event logs?
  • When you attempt to get a snapshot, do any error messages or warnings appear in the event logs?

    Hi,

    I seem to be having the same problem with a winforms application (which consists of migrated VB.NET code and C# code - it also uses COM to access old VB6 code)

    The application event log has a few errors -

    Hanging application RedGate.Profiler.UI.exe, version 3.1.0.20, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Hanging application RedGate.Profiler.UI.exe, version 3.1.0.20, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Hanging application MyReportingWizard.exe, version 6.9.0.29877, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    The above happened last night at about 8:30

    when i came into work this morning, it was still "taking a snapshot", and the following appeared at about the same time i attempted to attach a vs2005 debugger to application and then killed the app after it was too painful -

    .NET Runtime version 2.0.50727.832 - CLR 2.0 does not support profilers written for CLR 1.x

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    What version of ANTS Profiler is this and what versions of .NET Framework are present? I'm not aware that you can't use a .NET 1.1 profiler on a system with only .NET 2.0 installed, but that does look like the cause of the problem, according to the error message.

    I guess you could either upgrade Profiler to 2.7x or install .NET Framework 1.1. The last minor version of ANTS Profiler will use the .NET 2.0 profiling API and I'd wager upgarding Profiler would be the easiest option. You can get this from our FTP site at ftp://ftp.red-gate.com/old/ANTS/ANTSProfiler271.exe.
  • I'm using the latest version (i simply downloaded the demo version and installed that. I have .NET v1.0.3705, 1.1.4322 and 2.0.50727 installed on my system.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Is there an entry in the application log at this time, either from ANTS Profiler or .NET runtime as a source, that says anything along the lines of 'failed to cocreate profiler'?
Sign In or Register to comment.