Could not find location of SqlCmd

Hi Folks,

I have a self-hosted agent for Azure DevOps that runs a deployment to an SQL Server.  It is failing with the error "Could not find location of SQLCMD".

I did find a year old forum post in the old ReadyRoll forum stating how SQLCMD is located.  My SQL Server has the registry entries it describes (I just don't know if it is still relevant).

The agent has access to the SQL Server.  I have other agents that run without problems to other SQL Servers.  I can't find any differences between them and this problem agent.

I've tried different users (System, Network Service, even a Domain Admin User). I've tried different SQL Authentications (different SQL Users, and Domain Users).  Still... the error.

I just don't have any idea what to check, change, test, etc. to resolve this.  Any insight would be greatly appreciated.

Thanks, Greg

Best Answer

  • MondayMonday Posts: 77 Silver 3
    Accepted Answer
    It should be in the PATH. If you need to add or update to the PATH statement on the server you will need to reboot it for the agent to see the changes.

Answers

  • gregfiggregfig Posts: 22 Bronze 1
    Thank you Monday... your response helped me do a little Joe Friday and was able to figure it out! :)  For some reason the ODBC SQL tools (SQL Cmd Line Utils) didn't install on the client.  Once I manually installed them, everything was good.

    Thanks Again!
Sign In or Register to comment.