Memory Profiler 4.3.0.126 Hangs While Taking Snapshot

I'm trying to profile the memory of a CAB/SCSF C# application. The initial snapshot works fine, but after my app has loaded a few of its modules, the profiler hangs trying to take a snapshot. I've tried installing the V5 release - This works fine for the first snapshot, but crashes the app on the second attempt. I've tried with both debug & release builds. Any ideas?

Tech. information:
App footprint: ~80MB
O/S: XP Pro SP2
Machine: 8 CPUs, 3 GB RAM, 200GB free on disk.

Comments

  • Hi Rick,

    sorry for the trouble you are having.

    Can i just ask - was it the latest EAP build of V5 you tried? We just released another build last night (build 450) which you can get from here:

    http://www.red-gate.com/MessageBoard/vi ... php?t=8589

    If it was that build that was still causing trouble then it would probably be easier to try and get the issue in V5 resolved as we are currently working on it and releasing new builds every 10 days or so.

    You will see the EAP feedback menu in V5. If you could open the log file directory and send the log files from that to:

    [email protected]

    referencing this post with some additional details of what you are profiling or any other information you feel might be useful and we will try to find out why the problem is happening.

    Thanks!

    Stephen
  • Thanks Stephen, I've sent you the log via the EAP Feedback Form.
  • Thanks Rick,

    this is going to take more investigating. I've dropped you an email about it so when you get the time we can hopefully deal with it then.

    Cheers,

    Stephen
Sign In or Register to comment.