MySql compare doesn't start up

I installed the tool half a year ago. It worked like a charm but i rarely needed it. Now i'm trying to use it again and it won't start up. On double click the icon a black cmdline window opens in a split second and closes again.
What i tried:
1) re-install the application - no success
2) runned it on the commandline: start MC.exe - no success
3) runned it on the commandline: MC.exe /db1 <... all parameters to perform a diff...> - logs that it performed a compare
4) Googled for startup problems with exe's, found some tweaks with the register - no success
5) Explored all the different loggings from Windows: There is no error logging on the timestamp i open the application. The "red-gate" logging is empty.
I work on Windows 10 and MySql compare version 1.0.1.4

Any one an idea how to solve this one?

Thanks in advance!
Bart Devos
Tagged:

Best Answer

  • David AtkinsonDavid Atkinson Posts: 1,264 Gold 5
    Accepted Answer
    Are you trying to launch the GUI or just use the command line? The GUI is invoked using RedGate.MySQL.Compare.SchemaUI.exe
    David Atkinson
    Product Manager
    Redgate Software

Answers

  • Which version of MySQL are you connecting to?
    David Atkinson
    Product Manager
    Redgate Software
  • bduitpbduitp Posts: 3 New member
    Dear David, thanks for your quick response. I use MySql server 5.6.39 on my local machine. Note that i didn't change the version since the last time i used MySql compare.
  • bduitpbduitp Posts: 3 New member
    You 're absolutely right! I had an alias in the start menu that worked at the time but not today. As i removed and re-installed MC i invoked the application directly from the Programs (x86) directory, thinking the MC.exe was the application. Sorry for this non-issue and thank you so much for your help!
    Kind regards
    Bart Devos.
Sign In or Register to comment.