Profiler not working on IIS

Hi there,

details:
Windows Enterprise server 2008
IIS 7.0
asp.net application on Asp.net 2.0, and .NET 3.5 hosten in IIS.

Trying to launch ants performance profiler (version 4.3.0.196)
Always getting exception:
Could not launch the task to be profiled.
RedGate.Profiler.Engine.Exceptions.CannotStartSessionException
  at bI.Launch()
  at RedGate.Profiler.Session.ProfilerSession.j()

Caused by:

Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartIisSessionException
  at bO.PerformLaunch()
  at bI.Launch()

Caused by:

Timed out waiting for port 80 on 127.0.0.1 to become available
RedGate.Profiler.Engine.Startup.IIS.PortTimeoutException
stack trace: 
  at RedGate.Profiler.Engine.Startup.IIS.IISUtilities.WaitForPort(IPAddress address, Int32 port, Int32 timeout)
  at RedGate.Profiler.Engine.Startup.IIS.IISUtilities.WaitForPort(String hostname, Int32 port, Int32 timeout)
  at bn.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at RedGate.Profiler.Engine.Startup.IIS.IISStarter`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
  at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)
rethrown at [0]: 
  at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
  at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
  at RedGate.Profiler.Engine.Startup.IIISActuator`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
  at bO.PerformLaunch()


tried both classic .NET pool and integrated.

Security Event log shows nothing interesting, some special logons.

While application log shows:

1:
The configuration manager for Windows Process Activation Service (WAS) did not initialize. The data field contains the error number.
2:

Windows Process Activation Service (WAS) is stopping because it encountered an error. The data field contains the error number.

Same goes for IIS, or for other port. Firewall is turned off. PC is in domain.
Any more info needed?

Comments

  • Hi,
    I'm sorry that the profiler isn't working for your application.

    I think what's happening is that the modified applicationHost.config file that the profiler is making isn't valid in some way.

    I wonder if you could send me your original applicationHost.config, which can be found in:
    C:\Windows\system32\inetsrv\config
    And any of our modified copies, which can be found at:
    %USERPROFILE%\AppData\Local\Red Gate\ANTS Performance Profiler 4
    and are named like tmp*******.config

    IF you could send these to [email protected] and reference this forum thread in the email, that would help.

    Thanks,
    Alex
    Alex
    Developer,
    Red Gate .NET Tools
  • Hi,
    While looking at windows server 2008, we found a way to get the same exception that you have. An instance of the "w3wp.exe" process may have been left by a previous profiling session exiting incorrectly. This simply needs to be ended in task manager (or by restarting the computer) to fix the problem if this is the case.

    Hope that helps,
    Alex
    Alex
    Developer,
    Red Gate .NET Tools
Sign In or Register to comment.