What are the challenges you face when working across database platforms? Take the survey
Options

When will SSMS Integration Pack 2.1 be compatible with SSMS v18+ ?

I have been getting the following InstallFailure message ever since I migrated to SSMS v18+.
"Cannot install SSMS Integration Pack 2.1 - SSMS 2012, 2014, 2016 or 2017 required"

MCTSQL
Tagged:

Best Answer

  • Options
    Tianjiao_LiTianjiao_Li Posts: 684 Rose Gold 5
    edited August 19, 2019 9:28AM Answer ✓
    If you had another version of SSMS installed, you should uninstall Redgate Bundle before you uninstall it.

    You can workaround this issue by reinstalling the old version of SSMS, uninstall Redgate Bundle, then uninstall the old version of SSMS.

    Alternatively,  you can uninstall the corrupted installation using this free ReveUnininstaller: https://www.revouninstaller.com/revo_uninstaller_free_download.html and you may need to turn on “Show system components" from the RevoUninstaller options. It is off by default. Then, you can try reinstalling the bundle.
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?

Answers

Sign In or Register to comment.