How is SQL Prompt helping your team? Share your experience.

Tabs are no longer reconnecting when SSMS starts up

JimFJimF Posts: 49 Bronze 3
I have started to notice that when I start up SSMS my tabs are opening, but not always reconnecting. I have confirmed that I do indeed have "Automatically reconnect restored tabs" checked.  All of the tabs in question are connected via Windows Authentication, so saved credentials are not an issue in this case.

I am running SSMS v18.1 and SQL Prompt v9.5.12.10845. I am (re)connecting to SQL v13.0 (e.g. SQL Server 2016).

If there's any other information you require, please let me know.
Jim

SSMS About box for component details

Answers

  • It's difficult to troubleshoot if the issue is intermittent. Few questions would help:
    1- how many tabs were open when this issue occurred and were all tabs not reconnecting?
    2- were the tabs that didn't reconnect from one specific database?
    3- do you have this issue with any other version of SSMS?
    4- if you restore the Prompt options to default (SQL Prompt ->Options->Restore all defaults), restart SSMS, does it help?
    5- do you notice any pattern when this issue occurs?
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
  • JimFJimF Posts: 49 Bronze 3
    It's difficult to troubleshoot if the issue is intermittent. Few questions would help:
    1- how many tabs were open when this issue occurred and were all tabs not reconnecting?
    2- were the tabs that didn't reconnect from one specific database?
    3- do you have this issue with any other version of SSMS?
    4- if you restore the Prompt options to default (SQL Prompt ->Options->Restore all defaults), restart SSMS, does it help?
    5- do you notice any pattern when this issue occurs?

    1) This last time, 28 tabs were reopened, but not connected. 3 of those tabs were reconnected. Most of the unconnected tabs were pointing to the same server/database as the reconnected ones.

    2) Mostly one since that is what I am currently focused on right now, but as I mentioned in #1, I did get a couple of reconnects to the same server/database.

    3) Not that I remember. If I did, it was a long time ago.

    4) Oh! That sounds drastic. OK, I did an Export of all of my settings and then clicked Restore all defaults. I connected a couple of tabs as a test, then restarted SSMS. I noticed that most of my tabs now reconnected with the exception of a couple that used a SQL User/Password to connect, even though I have saved the password in SSMS.

    5) The only pattern that I noticed is that I have tabs open and connected, I quit SSMS. I restart SSMS, and most of my tabs are not reconnected.

    Now I have to try and figure out what all of the settings are that I lost, like all of my custom aliases :-(
  • JimF said:
     I noticed that most of my tabs now reconnected with the exception of a couple that used a SQL User/Password to connect, even though I have saved the password in SSMS.

    This is a known issue which we logged as SP-7650 when using SQL Authentication. We haven't got a ETA for the fix, so please keep an eye on the release note.

    So sorry about the lost of your custom aliases. If it's too difficult to redefine your custom aliases, you can take few screenshots of the default settings, then revert to your old setting and manually go through the difference between your settings and the default one.


    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
  • ahdungahdung Posts: 28 Bronze 2
    @Tianjiao_Li Could you tell me what the progress of SP-7650.
  • TomWTomW Cambridge Posts: 108 Gold 1
    Hi everyone,

    Tom from the Prompt team here. We've fixed this issue and we'll be shipping that fix to you all later this week. Sorry for the inconvenience this has caused in the meantime.

    Please get in touch if you have any other issues.

    Thanks.
    Software Engineer for SQL Prompt
    Redgate Software
  • TomWTomW Cambridge Posts: 108 Gold 1
    This release should now be available to you all. Please get in touch if there are still any issues.

    Thanks,
    Tom
    Software Engineer for SQL Prompt
    Redgate Software
Sign In or Register to comment.