What are the challenges you face when working across database platforms? Take the survey
Options

How/when are SQL search indexes created/updated

MSAMSA Posts: 6 New member
Hello,
I just installed SQL search for the first time and tried to search for something, but am not getting any results.
When I click the "Index" menu, I see two items:
  • Reindex
  • Cancel Indexing
Is "Cancel Indexing" always there, or only while it is building the index? Does this mean it is not yet done building the index and that's why there are no results? I tried clicking both items, but nothing happens.
There is no feedback at all when I say "Cancel indexing", and the menu item stays.
When I click "Reindex", nothing is hapening either (no confirmation, nothing saying "starting indexing" or anything...
How is this supposed to work?
How do I know if it is done with indexing, or how far along it is in building the index?

Thanks,
Mark

Answers

  • Options
    Hello Mark,

    Both of those options are present when you select the Index portion of the SQL Search plugin.

    Regarding your SQL Search not getting any results, do you have any other Redgate products installed, in particular SQL Prompt?  If the answer is yes, what version of SQL Prompt is currently installed?  

    I ask this question, due to updates to SQL Search performed in March 2019, where a later version of SQLite libraries conflicted with the SQLite libraries used in SQL Prompt which resulted in the 'SQLite.Interop.dll' errors similar to the one found in your log file.  If using SQL Prompt V9.4.12.8426 or earlier, I recommend that you upgrade to at least V9.4.16.9097 of SQL Prompt.

    Let me know if that helps you out.

    Sean Quigley | Product Support Engineer | Redgate Software

    Have you visited our Help Center?





  • Options
    MSAMSA Posts: 6 New member
    I had nothing else installed yesterday and SQLSearch was the version I had just downloaded yesterday.
    In the meantime, I installed all other components of the Essentials ToolBelt and now search works.
    It also shows the "Indexing" notification with the moving green bar when I open a new database connection.
    Not sure what was wrong yesterday.
    Thanks,
    Mark
Sign In or Register to comment.