IIS is not installed on this computer

windows 10 Education edition
ANTS performance profiler 10.1.5.1275
my iis is installed,why get this error?
Tagged:

Answers

  • Hi @gavinluo

    Please can you provide the following information:
    • the version of IIS you are using
    • the steps you have already tried
    • any error messages ANTS Performance Profiler has generated, including any in the log files


    Kind regards

    Victoria Wiseman | Redgate Software
    Have you visited our Help Center?
  • gavinluogavinluo Posts: 6 New member
    edited July 9, 2019 11:45AM


    The log file :
    C:\Users\Gavin\AppData\Local\Red Gate\ANTS Performance Profiler 10\antsprofiler-b09eb13d-8adf-4204-a686-f15b5d6f2bdc.log

    09 Jul 2019 19:37:50.113 [1] INFO  RedGate.Profiler.Logging.LogService - Starting new ANTS Performance Profiler 10 session
    09 Jul 2019 19:37:50.128 [1] INFO  RedGate.Profiler.Logging.LogService - Assembly version: 10.1.5.1275
    09 Jul 2019 19:37:56.242 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Requesting registered installed browsers from reader.
    09 Jul 2019 19:37:56.246 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserRegistryReader - Collating all registered installed browsers on the local machine.
    09 Jul 2019 19:37:56.269 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Found registered browser 'Chrome'.
    09 Jul 2019 19:37:56.277 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Found registered browser 'Internet Explorer'.
    09 Jul 2019 19:37:56.288 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Found registered browser 'Edge'.
    09 Jul 2019 19:37:56.290 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserRegistryReader - Local machine is 64bit; will check for any additional distinct browsers in the WOW6432Node.
    09 Jul 2019 19:37:56.305 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Default browser's install name found. Value: 'ChromeHTML'.
    09 Jul 2019 19:37:56.444 [1] WARN  RedGate.Profiler.OS.Local.LocalWindowsVersionInspector - Detected Windows version: Windows 8.1  (6.3 64-bit)
    09 Jul 2019 19:37:56.450 [1] WARN  RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is not supported on installed OS version.
    09 Jul 2019 19:38:29.699 [16] ERROR RedGate.Profiler.Logic.Controllers.Setup.SetupController - Failed to generate history overview entry
    System.NullReferenceException: 未将对象引用设置到对象的实例。
       在 RedGate.Profiler.Logic.Controllers.Setup.ProjectType.AttachSettingsController.GenerateModel(AttachSettings settings)
       在 RedGate.Profiler.Logic.Controllers.Setup.ProjectType.ProjectTypeControllerBase`2.GenerateProjectOverview()
       在 RedGate.Profiler.Logic.Controllers.Setup.SetupController.GenerateHistoryOverviews(IEnumerable`1 history)
    09 Jul 2019 19:38:29.795 [15] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Not launching trigger process
    09 Jul 2019 19:38:29.799 [15] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Starting trigger process C:\Program Files\Red Gate\ANTS Performance Profiler 10\RedGate.Profiler.Trigger_x86.exe
    09 Jul 2019 19:38:29.796 [1] INFO  RedGate.Profiler.Logic.Controllers.Session.FrontEnd.BrowserProvider - Default browser's install name found. Value: 'ChromeHTML'.
    09 Jul 2019 19:38:30.071 [15] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Trigger process has connected
    09 Jul 2019 19:38:30.073 [15] INFO  RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - A suitable trigger process is now available
    09 Jul 2019 19:38:35.676 [15] INFO  RedGate.Profiler.Engine.Startup.Basic.Attacher - Found runtime version v4.0.30319

  • Jessica RJessica R Posts: 1,034 Rose Gold 3
    Thanks @gavinluo! That's really odd- in the past, we've only seen this issue come up with LTSB Windows systems, which the profiler doesn't officially support. It looks like you're on Windows 10, however.

    Could you please send across a screenshot of About your PC> Windows specifications?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • gavinluogavinluo Posts: 6 New member



    and my program is published on Windows Server 2008R2, i even tested on it and get this error .  logs in attachment 





  • Jessica RJessica R Posts: 1,034 Rose Gold 3

    Thanks @gavinluo!

    Can I check--is that the Windows 10 Education Edition? Please let me know and I'll check with our developers if that edition is supported.

    Note: A possible workaround could be to run your IIS application normally and then use the Attach to .NET 4+ process to attach to the w3wp.exe process. (The downside though is that you can only get Sampling level detail.)

    Regarding the "Timed out waiting for port 8013 on 127.0.0.1 to become available", can I first make sure--is the application you are profiling running locally on your laptop? The profiler does not support remote profiling, I'm afraid.

    If the site is indeed running locally, the logs unfortunately don't have any further information, but can you kindly help us get more detail:
    • Check Event Viewer for any errors regarding the profiler or your application
    • Try running the profiler explicitly as administrator in case this is permissions related. You can get the 'run as admin' option by pressing shift as you right-click on the profiler (I realize you may be an administrator on your machine, but UAC may still block some operations if enabled.)
    • If you're alright with IIS restarting - try having the profiler start your application on the original port (from 'show server options')

    Thank you!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Jessica RJessica R Posts: 1,034 Rose Gold 3
    Hi @gavinluo!

    Any luck with the suggestions above?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • gavinluogavinluo Posts: 6 New member
    edited July 24, 2019 12:53PM
    for  Windows 10 Education Edition:
    1. run profiler as administrator  even display "iis is not installed on this computer"
    2. the application event has no errors event

    for Windows Server 2008R2:
    1. run profiler as administrator  even show 

    2. the application event has no errors event
    3. try having the profiler start your application on the original port  ,that is ok 


  • Jessica RJessica R Posts: 1,034 Rose Gold 3
    Thanks @gavinluo!

    Our developers are going to look into the issue with Education Edition and I'll post here once we have an update.

    Regarding the issue on the older server, this will best be handled via a Support ticket. if you have a currently supported license, can you kindly open a ticket by email us at [email protected]?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • gavinluogavinluo Posts: 6 New member
    that is two problem wait to solve
    1. for Windows 10 Education Edition:
    2. for Windows Server 2008R2

    i have User licenses Support & Upgrades Until June 29th, 2020 , and how to open a ticket ? Copy this topic in email ? 


  • Jessica RJessica R Posts: 1,034 Rose Gold 3
    Hi @gavinluo!

    Yes, you can just copy the topic into an email with a link to this forum post.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Jessica RJessica R Posts: 1,034 Rose Gold 3
    Thanks! We've received the ticket and I'll reply on the 2008r2 issue there.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.