Competition: What’s your favorite Redgate tool? Enter now.

SQL Prompt 9.5.8.10521 won't install in VS2019 or SSMS18.1

Hopefully someone has some suggestions...

I have VS2019 and SSMS18.1 installed, and previously had SQL Prompt 9.4.9.7873 installed (before installing either VS2019 or SSMS18.1 - I've uninstalled the SSMS that was previously installed).

When I try and run the latest installer (downloaded from the stickied thread), it shows the following error.
Trying to uninstall the current version shows the same message.

Any ideas?

Best Answer

  • SeanFlemingSeanFleming Posts: 2 New member
    Accepted Answer
    In case anyone sees this in the future - the issue was actually the uninstall!

    I reinstalled SSMS 17.9, then uninstalled SQL Prompt, then installed the latest SQL Prompt.
    This worked, even in 18.1.
    I then uninstalled SSMS 17.9.

    All good now!

Answers

  • ken.powersken.powers Posts: 2 New member
    Thanks for the tip. In my case, I have VS2017 and SSMS 18.1 installed. My error message was slightly different:



    I was about to install 17.9.1 again, but then I got a similar error message from the SSMS installer. So on a hunch, I just rebooted my machine and tried again. This time the Red-Gate install was successful.
Sign In or Register to comment.