Training: Reporting in SQL Monitor. Watch now.

SQL Monitor Upgrade

JonVCJonVC Posts: 4 New member
I've just upgraded from version 8.0.20 to 9.0.13, however when I launch the web console it's still showing at version 8.020 and that an update is available. Yet when I open the installer file it says it's already installed. 
Why would the web console not be updated?
Tagged:

Best Answer

  • Dan BDan B Posts: 287 Gold 5
    Answer ✓
    Hi JonVC,

    That would suggest the install hasn't done everything and should have reported an error here.

    If you open services.msc you should see a SQL Monitor Base Monitor Service. If you right click on this and hit properties you will see the path to executable Which will be something like

    "C:\Program Files\Red Gate\SQL Monitor\Web\RedGate.SqlMonitor.UI.Server.Service.exe"

    If you navigate to the folder C:\Program Files\Red Gate\SQL Monitor\Web and right click on the named .exe what version is shown?

    I think the best next steps would actually be to uninstall SQL Monitor and then Install version 9 fresh. If you point the v9 at the existing database you wont lose any data doing this.
    Kind regards,
    Dan Bainbridge
    Product Support Engineer | Redgate Software

Answers

  • Hi JonVC

    Could you either attach screenshots here of the installer and the website or send these over to [email protected] please. It would help to see which stage of the website and installer is showing this.

    If the installer is failing when it gets to the database step I would advise uninstalling the website and base monitor and re-installing but I can confirm this after seeing the relevant messages.
    Kind regards,
    Dan Bainbridge
    Product Support Engineer | Redgate Software
  • JonVCJonVC Posts: 4 New member
    Hi Dan. Attached are screenshots of the start menu showing "SQL Monitor 9", the error message when trying to launch the installer again, and the current version still showing as version 8.

    The installation of version 9 went without errors. The issue is that the website is still showing at version 8. Is there anything else besides running the installer that we need to do to have the website reflect the upgrade? 

    Thanks.

    Jon.
  • JonVCJonVC Posts: 4 New member
    Thanks Dan. A re-install has resolved the issue. Thanks.
Sign In or Register to comment.