What are the challenges you face when working across database platforms? Take the survey
Options

Why cannot my encrypted app to run

Hello  
   I have an application (C# code) , i want to start working with smart assembly but when i download the trail version and start testing my application failed to run after i rebuild it.  How can any body help me in this and what information you need from me to investigate more?

Tagged:

Best Answer

  • Options
    Russell DRussell D Posts: 1,324 Diamond 5
    Answer ✓
    In these cases its best to strip your assembly back to basics, ie build it with zero obfuscation. Then, turn things on one by one until it breaks. This gives you both a point at which you can release (ie breakage - 1 step), and highlights what obfuscation type might be causing it.
    Have you visited our Help Centre?

Answers

  • Options
    JaradatISCOJaradatISCO Posts: 9 New member
    Thank you , yes i did it and the issue appeared after i select obfuscation step. Cause we use jollan tool for language translation and this tool produce Dll resources and the exception appeared after the language form appear and before the load of the main application. 

    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.TypeInitializationException: The type initializer for 'ShamelLight.Utility' threw an exception. ---> System.Resources.MissingManifestResourceException: Could not find any resources appropriate for the specified culture or the neutral culture.  Make sure "ShamelLight.MultiLang.resources" was correctly embedded or linked into assembly "ShamelLight" at compile time, or that all the satellite assemblies required are loadable and fully signed.
       at System.Resources.ManifestBasedResourceGroveler.HandleResourceStreamMissing(String fileName)
       at System.Resources.ManifestBasedResourceGroveler.GrovelForResourceSet(CultureInfo culture, Dictionary`2 localResourceSets, Boolean tryParents, Boolean createIfNotExists, StackCrawlMark& stackMark)
       at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo requestedCulture, Boolean createIfNotExists, Boolean tryParents, StackCrawlMark& stackMark)
       at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo culture, Boolean createIfNotExists, Boolean tryParents)
       at System.Resources.ResourceManager.GetString(String name, CultureInfo culture)
       at System.Resources.ResourceManager.GetString(String name)
       at ..(Int32 )
       at ..(Int32 , String )
       at ShamelLight.Utility..cctor()
       --- End of inner exception stack trace ---
       at ..›–()
       at ..(Object , EventArgs )
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at Œ.‡.‡(EventArgs )
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

  • Options
    Russell DRussell D Posts: 1,324 Diamond 5
    Ok, if you're still having issues with this it might be best to send a reproduction into support so it can be looked into.
    Have you visited our Help Centre?
  • Options
    JaradatISCOJaradatISCO Posts: 9 New member
    no it doesn't solved ! how can we manage this issue to be solved
  • Options
    JaradatISCOJaradatISCO Posts: 9 New member
    Look , the main reaon for this issue is (obfuscation process) cause i use third party DLL's (for languages)

    and the output is Resources.dll come from (.resx) files.

    These resourced loaded in load page then after encryption they did a crash as i mentioned above.

    and till now i cannot exclude any class or DLL from being obfuscated since it takes long time and crashes when i log in to that page using your tool

  • Options
    Russell DRussell D Posts: 1,324 Diamond 5
    We would need a reproduction to investigate further.
    Have you visited our Help Centre?
  • Options
    niyaleonniyaleon Posts: 1 New member
    Assembly causing your C# application to fail, follow these steps:
    1. Ensure proper configuration.
    2. Review error messages.
    3. Verify version compatibility.
    4. Backup your project.
    5. Check obfuscation rules.
    6. Use debugging tools.
    7. Seek Redgate support if needed.
    8. Temporarily disable Smart Assembly for testing.

  • Options
    rajesh891rajesh891 Posts: 1 New member
    niyaleon said:
    Assembly causing your C# application to fail, follow these steps:
    1. Ensure proper configuration.
    2. Review error messages.
    3. Verify version compatibility.
    4. Backup your project.
    5. Check obfuscation rules.
    6. Use debugging tools.
    7. Seek Redgate support if needed.
    8. Temporarily disable Smart Assembly for testing.

    Hey,
    Can you please explain how to check obfuscation rules..

    It will be a great help for me.

    Regards,
    Rajesh Pawar
  • Options
    doramasmp4doramasmp4 Posts: 1 New member
    You can check your cache that is preventing your app from running. Or you can use our blog to see the other settings recommended for this.
    https://doramasmp4.dev/tag/doramas-go/
  • Options
    wmwgoldwmwgold Posts: 1 New member
    You can check your cache that is preventing your app from running.  You may check WhatsApp Gold
Sign In or Register to comment.