Reflector 10 with VS 2019 - F12 not working

I have a Windows 2019 server with VS 2019 Pro and .NET Reflector VS extension 10.1.5.1419 installed and the Goto Definition F12 doesn't work from either the menu or directly with the F12 key.
I have tried removing and reinstalling the extension with no luck. I have also tried running VS 2019 as administrator and adding/removing the extension and I have also tried clearing the cache but still no luck.
What do you suggest I try next?
Tagged:

Comments

  • PeterSimpsonPeterSimpson Posts: 5 New member
    Same experience here, disappointing given that VS 2019 was in beta for quite a while.
  • Chris GorringeChris Gorringe Posts: 16 Bronze 2
    Hi RedGate support, can we have a response to this problem please?  :)
  • PeterSimpsonPeterSimpson Posts: 5 New member
    Hi Redgate Support,

    I paid Redgate £108 in May to upgrade my Reflector 9 license to version 10 and it seems that I have wasted this money because I still can't see decompiled assemblies in VS2019! 

    Please can I have my money back and please will you respond to this thread, there are obviously others in the same position as me.

    Thanks, Peter
  • Alex BAlex B Posts: 713 Diamond 1
    Hi all,

    I've just installed fresh VS2019 (16.1.5) and installed .NET Reflector from the Visual Studio Marketplace and the default shortcut in VS 2019 is to use F12 for go to definition (this is the Tools > Options menu):


    And you can see this in the Right click context menu as well:


    The entry for the NetReflector.GotoDefinitionF12 doesn't actually have anything populated for a shortcut key because the default behavior of Visual Studio is to do so as shown above.

    The default for Shift+Alt+G is for going to a decompiled definition:

    So unless it was decompiled with .NET Reflector this will not do anything.


    Can you check the Tools > Options menu and check the Keyboard shortcut settings and let me know what is shown?  Did you import settings from an earlier Visual Studio installation or have you customized these settings at all previously?

    Kind regards,
    Alex

    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • PeterSimpsonPeterSimpson Posts: 5 New member
    Hi Alex,

    Thanks for your comprehensive response. My settings look identical to yours: F12 is mapped to Edit.GoToDefinition and SHIFT/ALT/G is mapped to EditorContextMenus.CodeWindow.GoToDecompiledDefinition.

    As an experiment I assigned the F12 key to the NETReflector.GoToDefinitionF12 entry but nothing then happened when I pressed F12, re-assigning it back to Edit.GoToDefinition brought back the current behaviour of showing the method outline but without decompiled detail.

    Regards, Peter
Sign In or Register to comment.