Copying Backups to S3 Storage

CamromereCamromere Posts: 12 New member
I am new to SQL Backup and am setting up my jobs now. I want to configure them to copy the backups to a specific directory in one of our S3 Buckets. In the Backup Job Configuration, I have selected "Copy backup to hosted storage", I have configured our S3 Bucket and it shows it is linked successfully. Under that, there is a "Folder:" location presumably to define into which folder I want the backup to copy. However, I've tried foldername\foldername and I've tried foldername/foldername, but the backups are not copying to S3. What is the format the specific folder needs to be in for the copy to S3 to work? The only error I see is this, which is not overly helpful:

5/20/2019 10:15:42 AM: COPYTOHOSTED error: Unable to upload B:\SQL_Backups\MiscDBs\master\FULL_(local)_master_20190520_101529.sqb to hosted storage (error 10 - Upload failed. The backup file was not copied to hosted storage: One or more errors occurred.)



  • Options
    Russell DRussell D Posts: 1,324 Diamond 5
    Do the log files (https://documentation.red-gate.com/sbu10/troubleshooting/sql-backup-log-files) contain any useful information?
    Have you visited our Help Centre?
  • Options
    jrguayjrguay Posts: 11 Bronze 2
    I agree with @Russell D. Check the logs for signs of issues with permissions, bandwidth or other security alerts.
    Not quite the same, but related, in Azure, I have needed to make folders and containers public in order to make it work.
  • Options
    I am having the same issue as above.

    failed with the error "COPYTOHOSTED error: Unable to upload C:\Program Files\Microsoft SQL Server\MSSQL13.MSSQLSERVER\MSSQL\Backup\System DB Backups\master\FULL_(local)_master_20210120_150229.sqb to hosted storage (error 10 - Upload failed. The backup file was not copied to hosted storage: Method not found: 'System.Threading.Tasks.Task Amazon.S3.Transfer.TransferUtility.UploadAsync(Amazon.S3.Transfer.TransferUtilityUploadRequest, System.Threading.CancellationToken)'.)

    On two servers, the backup with copy to S3 works as expected. On two others, I get that failure described above. I had our Infrastructure team check for connectivity and networking or VPC issues and they found none. All four servers are same EC2 instance type with same OS and same version of MS SQL Server. Backups jobs are configured the same way on all servers. They are all pointed to same S3 bucket, but different folders. Does anyone know anything else we can check?
  • Options
    In the folder where the SQL Backup Agent executable (SQBCoreService.exe) is installed in, you should find the hosted storage upload executable file (SQBHostedStorageClient.exe), and 2 Amazon client libraries (AWSSDK.Core.DLL and AWSSDK.S3.dll).  Could you please check if the version numbers of those files are consistent across your servers?

    Also, do you have .Net 4.5 installed on the servers where the upload fails?
    SQL Backup - beyond compression
  • Options
    DeraldSmithDeraldSmith Posts: 3 Bronze 1
    executable file (SQBHostedStorageClient.exe), and 2 Amazon client libraries (AWSSDK.Core.DLL and AWSSDK.S3.dll) are the same across all servers both the ones where it works and the ones where it doe snot work. Also, .NET framework version is .Net 4.7.
Sign In or Register to comment.