What are the challenges you face when working across database platforms? Take the survey
Options

SQL Compare was unable to save your project; any changes you

BellisioBellisio Posts: 26
edited February 17, 2009 12:27PM in SQL Compare Previous Versions
When leaving SQL Compare, or closing a project, I get the error above. It tells me the file in the /Projects folder is being used by another process.

I also notice that most (but not all) times now when I use SQL Compare, it seems to duplicate the current project, so my comparison list has what looks like several projects with the same comparison selected.

I have tried deleting all within the Projects folder (saving it first), and starting from scratch, but the problem persists.

Thanks for any help.

Comments

  • Options
    Thanks for your post.

    I'm not sure what could be causing this issue, as I haven't heard of this happening before.

    Do you know if anything else is configured to access the project files? Maybe something like a command line job triggered through a scheduled task could be accessing the file.

    You could try using processmon from sysinternals and see what else has a handle on the project file when you exit the application.
    <http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx&gt;

    When SQL Compare 8.0 is released you will have the ability to explicitly save project files, so this kind of thing might not be an issue in the next release.
    Chris
  • Options
    Thanks for the start. I have downloaded the process monitor, and am now trying to figure out how to use it. Meanwhile, tried to uninstall SQL Compare, and then deleted my projects folder; re-installed from a fresh download, all to no avail. Problem seems worse than ever. I created a new project, worked in it, then closed it; and then my projects list had 3 items in it - all this same project.
  • Options
    Follow-up - although I never was able to figure out how to use process monitor (WAY too much information, and not easy to figure out how to isolate it for looking just at this folder useage); I tried something - moving my Projects folder from my My Documents, which is on a network drive; to the C:\Program Files\Red Gate folder. Keeping my fingers crossed, but seems to be working. Maybe something about being on the network drive vs. a local drive? As I said, I was working with a new workstation, perhaps the old installation was on a local drive, and I just didn't notice.
Sign In or Register to comment.