Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

SQL Prompt 9.5 does not install in Visual Studio 2019

Hi
I have ssms 17 and 18, visual Studio 2017 and 2019 installed on my machine.
when I install SQL prompt (newest version), it does not install in Visual studio 2019, it is installed in SSMS 17,18 and visual studion 2017.

have also tried to uninstall and reinstall, but it does not show in 2019 when i am editing a ssdt project :-(

does anyone have an idear?

Best regards 
Graves Kilsgaard
Tagged:

Best Answers

Answers

  • I can't reproduce this I'm afraid, in that i have the exact same environment that as you and its all installing fine.
    I'd look at installing the VSIX separately (https://marketplace.visualstudio.com/items?itemName=vs-publisher-306627.SQLPrompt) with logging and hopefully that will point you in the right direction.

    Have you visited our Help Centre?
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    hi
    the link does not point to a VSIX, i get the download exe file that i have installed before.

    Is there a VSIX file that i can install directly in VS 2019?

    Best Regards
    Graves
  • TravisDTravisD Posts: 3 New member
    I have the same problem as the OP, it works fine in all other places but VS2019.

    One thing that may be a contributer is that I had the 2019 RC installed and then upgraded it to the release version via a VS update. I wonder if that put things in a slightly different place or had something different that causes the install not to see 2019 correctly.
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    I installed VS2019 pro when it was released, and have not had any other installations of VS219 on my machine.
    I am running it together with newest release of VS2017 pro.
  • schultenschulten Posts: 1 New member
    I'm having the same problem - SQL Prompt doesn't work in VS 2019
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    Have joust installed newest version of SQL prompt and it is still not installing in VS 2019.

    First I uninstalled the old version and then I installed the new build.
    But no sql prompt in VS 2019 :-(

    Please advise!!
  • TravisDTravisD Posts: 3 New member
    Attached is the install log from my machine after a fresh uninstall/install. you will notice that I had 2019 running so it would show up in the log before closing it for the installation.
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    I have tried on different computers now, with same result.

    But I have now opened a support case, so hope to be able to post a solution at some point :-)
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    Well I got SQL prompt working on VS 2019 today.
    -uninstalled VS2019
    -Uninstalled SQL prompt
    -Restarted
    -installed VS2019
    -installed SQL prompt

    Now Sql prompt works in VS2019

    !!!!!! BUT NOW IT IS GONE IN VS2017 :angry:  !!!!!!

    Not easy using two development tools at once :dizzy:


  • awengaweng Posts: 7 New member
    You must be kidding with me. Does that mean I have to uninstall all my development tools (VS2017 and VS2019) to make the SQL Prompt installation to work right. If that is the case, it is time to say good bye to SQL Prompt. Why I am paying the product to bring trouble to myself. I have noticed the Red-Gate product quality is getting worse and worse. Any good replacements for Red-Gate tools?
  • KilsgaardKilsgaard Posts: 10 Bronze 1
    I have a ticket at Redgate support, and hope that they soon solves the problem :-)

    I have not found a tool that is better than SQL Prompt, have testet at lot at my last job, where I should decide what to use.

    so I hope that they soon solves the problem, so we again can use sql prompt on both 2017 and 2019...

  • Finally worked again, thanks! I had to force a refresh though by going to Extensions > SQL Prompt > Show List of Code Analysys Issues and then clicked the refresh button in the window that came up. Finally started highlighting and doing Intellisense correctly after that.
Sign In or Register to comment.