EXEC stored-proc autocomplete datetime

mbassmbass Posts: 2 New member
The autocomplete feature for EXEC stored-proc produces the wrong time (or time zone?) for datetime arguments.  Is there a setting somewhere for this?

For snippets, the placeholder $TIME$ works correctly.  But for autocomplete of EXEC procedure datetime arguments fills in the wrong time (or time zone).

Please advise.

Answers

  • Hi mbass,

    Are you referring to the Encapsulate as new stored procedure function?

    Best regards,
    Mac Frierson | Product Support Engineer | Redgate Software
    Have you visited our Help Center?

  • mbassmbass Posts: 2 New member

    No.  In a query window with SQL Prompt, type "EXEC " followed by the name of some stored procedure that has a datetime argument, then select the suggested name from SQL Prompt pop-up and press the Enter key to have the EXEC statement auto-completed. 

    SQL Prompt will auto-complete and put what appears to be the current date and time as a literal input for the formal datetime argument of the stored procedure.  But the time is different from my (and the DB) local time by four hours.  It appears to be auto-completing with UTC time instead of the local time (my local time is EDT).  How can I fix it to use my local time?


  • Hi mbass,

    Our developers have confirmed that converting the time to UTC is the intended behavior at the moment. I'm sorry to say that there aren't any plans currently to add a feature to disable this, but they have asked if you can please put a feature request for it on our Uservoice forum Here

    Our product managers use that forum as an important resource when considering new features and it allows other users to vote on the feature as well, to help add priority. They'll then post any updates to the request there.

    Kind regards,
    Mac Frierson | Product Support Engineer | Redgate Software
    Have you visited our Help Center?

Sign In or Register to comment.