Can not get the /includeIdentical to not show identical item

meklemblmeklembl Posts: 140 Bronze 2
edited February 5, 2009 12:53PM in SQL Compare Previous Versions
SQLCompare /S1:ATLAS /db1:DB1 /S2:SQL01 /db2:DB2 /includeIdentical:False
SQL Compare Command Line V7.1.0.197
==================================================================================================================================
Copyright c Red Gate Software Ltd 1999-2008

Serial Number: XXX-XXX-XXXXXXX

Registering databases
Creating mappings
Comparing
Replaying user actions
Creating SQL

Summary Information
===================================================================================================================================
DB1 = ATLAS.DB1
DB2 = SQL01.DB2

Object type Name DB1 DB2
Table [dbo].[Table1] == ==
Table [dbo].[Table2] == ==
Table [dbo].[Table3] == ==
Table [dbo].[ Table4] == ==
…
Larry M
Cleveland, OH USA

Comments

  • In the current commandline the includeIdentical option is only used when generating reports using the /report switch. In the 8.0 release, there will be commandline options to exclude additional, different and missing objects from the comparison and synchronization.

    May I ask in what situations you want to exclude identical objects from the comparison?

    Simon C
  • meklemblmeklembl Posts: 140 Bronze 2
    I have numerous databases in which the schema should be very close to the same, so eliminating the identical items allows me to focus on whether the difference is expected or not.
    Larry M
    Cleveland, OH USA
Sign In or Register to comment.