SQL Prompt freezes SQL Server Management Studio (SSMS) with select * statements

I'm not sure if others are facing this issue, but when I have multiple "Select top 10 *" statements at the top of my T-SQL file, SQL prompt doesnt like it and starts to slow down my SSMS instance any time I try to click off the top of the script.

When I say "performance issue" I'm talking about at lest 30-90 seconds of lag time and sometimes my SSMS actually completely freeze and I have to go into Windows Task manager and End Task.

Any and all optimization help greatly appreciated!!


Tagged:

Best Answer

  • sitedesignersitedesigner Posts: 2 New member
    Accepted Answer
    Specifically, what I was looking for was going to 
    SSMS > SQL Prompt > "Enable Code Suggestions" and unchecking that box, which can also be done with the shortcut "CTRL + SHIFT + A".

    Thanks for the help! This, combined with reducing the check for all databases (per your first link) helped improve my performance tremendously!.

    Cheers,
    David

Answers

Sign In or Register to comment.