Long Delay when Selected Columns in Tables & Views

Recently, I've been experiencing a long delay after modifying the columns to compare for a table. The wait cursor appears for about 30-45 seconds before the "Save" or any other action can be performed. Currently using SQL Data Compare 13.6.1.7928 Professional. Any ideas? Maybe the underlying project schema is corrupt?
Tagged:

Answers

  • SQL Data Compare attempts to simplify the mappings configuration each time you make a change.  However, the project file can sometimes get bloated after a large enough number of modifications to the mappings configuration, especially if the same project is reused across significantly different database schemas. 

    If this has happened, it might be worth creating a new project file and setting up your columns to compare again.

    If you're curious, you can take a look at the project file in Notepad and see what is going on under the hood, it's just an XML file although it's not particularly human readable.
    Software Developer
    Redgate Software
  • PDinCAPDinCA Posts: 637 Silver 1
    edited March 29, 2019 12:30AM
    I did create a new project.  DB has over 2000 tables.  I only care about ONE db schema - "pricemanager", so, about 20 tables, of which I care to compare just 11.  It takes nearly five full minutes just to get a tables and views page I can choose from.

    WHY, can I not simply "FILTER BEFORE RETRIEVAL"?  I know what I want, and it isn't 2000+ tables and 5000+indexes, et al.

    Like the OP, and I JUST upgraded to 13.4.5.6953 in hopes of some speed improvement (all hopes dashed when it ground on for the usual 5 mins), electing to omit the typical "who" columns for each of my 11 tables bearing these columns is, arguably, one of the WORST experiences a Product has to offer... 

    It is plain ridiculous to have to wait another five to ten minutes for every table I need to simply omit columns from...  And while here, it is also RIDICULOUS that to edit my project to include another table, I have to wait ANOTHER FIVE MINUTES for "it" to go back to the DBs I already went to, just to collect the SAME objects, in the SAME state...  GIVE US A "DO NOT RE-READ SCHEMA" OPTION!  (Both while we have a project open and need to edit, OR when we first open SDC - allow us to say, "JUST GET MY PROJECT'S CHECKED TABLES OBJECT DEFINITIONS" (getting 11 instead of 2500, now that's a speed-up waiting to happen...)

    I cannot attest to this being a "productivity enhancer" - simply because I waste tens of minutes while unnecessary schema reads are repeatedly done, and "it" goes off into la-la land simply when I exclude 4 columns from the a table compare!  Shocking it should be this bad at Version 13!

    And, when I have the GRID of results on show, GIVE ME A RIGHT-CLICK TO EXCLUDE A COLUMN, there and then, while the grid is on view - and "REFRESH JUST THIS TABLE" taking into account newly excluded columns...  SO. MUCH. FASTER.

    And this is on a MacBook Pro, with i7 processor and 16GB RAM, and SSD, so it's no slouch - and the servers are via wired 10GB Ethernet, about 150ft away, so no network latency.  

    ANY pointers RG can give to make this a usable tool would be greatly appreciated!
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • It sounds like you want us to be able to do partial registration, this is not currently something we support as you have found. If you want to suggest enhancements for SQL Data Compare then the best place to do so is at https://redgate.uservoice.com/forums/147879-sql-data-compare
Sign In or Register to comment.