Crash During Smart Rename

RMDRMD Posts: 18
Whenever I try to rename a table in my database using the Smart Rename feature, SQL Refactor crashes.

The crash occurs after I've chosen the new schema/name and clicked Next. The next step appears very briefly and then the Smart Rename window disappears.

I don't see any entries in the Event Log. How do I debug this issue? I'm using SQL Refactor 1.3.

Comments

  • I'm sorry that you've experienced this issue. It seems that for some reason the Smart Rename function can exit without any warning in certain situations. The developers are aware of this issue and will be looking into it to find out what is causing this. There is already a bug raised against this and for your reference the bug tracking code is: SR-699
  • +1 on this problem.

    Any update on SR-699?

    Is there a alpha / beta on this fix? I'm very keen to use this function to tidy up some badly named tables before a release to a source-code client.

    I have support - should I raise a support call?
  • How can I access your bug tracking database so I can see what progress has been made on this topic?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    We now have a fix for the Smart Rename issue in SQL Refactor 1.3. The fix not only eliminates the error that causes the window to disappear, but at long last an error dialog will appear with some information about the error and what had caused it. Feel free to get the update from:

    ftp://support.red-gate.com/Patches/SQL_ ... .4.0.4.zip

    If anyone still has problems, feel free to contact us at support (at) red-gate.com.
  • Hi,

    I have recently purchased ReFactor and the recently released upgrade. However I am still experiencing the problem that was originally posted but now with the error, "An error occured while generating the refactoring:\r\nIndex was outside the bounds of the array .\r\n Please contact [email protected]". This seems to only be on a handful of tables with only one new column name. I have tried those same tables with other new names which seems to work. I guess this is down to something already in my database but I have yet to search the 200 or so objects dependant on the table. Is this something I will have to fix manually or can you guys help?


    Thanks
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Have you tried the latest patch for Refactor (at this time, build 55)?

    http://www.red-gate.com/messageboard/vi ... php?t=9960

    If this doesn't work, by all means email support at red-gate.com and we'll go from there.
  • Hi,

    I have now and get "An error occured while generating the refactoring:Index was outside the bounds of the array. . Please contact [email protected]". Should have mentioned before I am on 2005 standard edition, SP1.

    Thanks
  • Using SQL Server 2008 any smart rename causes a crash with the following text immediately after pressing the 'Next' button for the new name:
    "An error occurred while generating the refactoring: Object reference not set to an instance of an object.. Pleae contact [email protected].
    I have applied the cumulative patch and the version is 1.5.1.74.

    Any fixes?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    I will open a support case for you and lock this topic. Object Reference not set... errors have too many possible causes and will never be completely "fixed". We'll have to work with you personally in this case to find out what the cause of the exception is.
This discussion has been closed.