Cannot Get RedGate toolbar to display in SSMS 2014 or SSMS17

I have both SSMS 14 and SSMS 17 on my machine.  The RedGate toolbar shows up only in SSMS 14 but the only button on the RedGate toolbar that works is the Tab History button.

We are installing sql server toolbelt version 5.1.  I need an admin to install this software and she has uninstalled all the components and reinstalled them and still no go. 

Additionally, we have tried just uninstalling the ssms integration pack 1 and SQL Search but that didn't work.

We have rebooted between all of these tries.  I have read through many of the posts but haven't found anything that works so far.

Tagged:

Answers

  • Hi @turdFerguson,

    There are a few parts I want to clarify here so I'll separate them out below.

    First, usually it's the case that the newer version of SSMS has been installed after the tools were already installed and appearing in the earlier version.  In this case you need to reinstall the tool.

    There are also occasions when the toolbar for the newly installed Redgate addons is collapsed down into a small space at the far right of the toolbar section when there are several long toolbars on the same line.  It will collapse into an area that looks like this and you can tell because if you click on the down arrow it will show the product buttons in a drop down:


    If you click and drag the grey dotted area to the next line down, it should expand the toolbar out.

    The second thing you mention is that the only button that works is the Tab History - is this in SSMS 2014?  And do the other buttons appear, they just don't open a tab?  A screenshot of this would be helpful.

    The last thing is that you say you are "installing sql server toolbelt version 5.1".  The Toolbelt itself doesn't have a version, it's just the tools within that are versioned meaningfully.  What tool is it that is version 5.1 (I think SQL Source Control is the only one it could be) or where are you getting this number?  If it is SQL Source Control, version 5.1 is from 2016 and does not support SSMS 2017, so you should update to the latest version for this to appear in SSMS 2017.

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
Sign In or Register to comment.