how to ignore sensitivity extented properties ?

After activating "Classify Data" from SSMS 17.9 (new feature of SSMS) there are extended properties that was added to tables. Sources Control (based on git) seams not able to ignore theses extended properties and show differences from database and source referential. Even if i choose to ignore extended properties in the comparison options.

Exemple of extended properties show by the commit in redgate source control : 

EXEC sp_addextendedproperty N'sys_sensitivity_label_name', N'Confidential - GDPR', 'SCHEMA', N'dbo', 'TABLE', N'ADM_SUPPLIER_EMBI', 'COLUMN', N'PHONE_1'
GO
EXEC sp_addextendedproperty N'sys_sensitivity_label_id', N'989ADC05-3F3F-0588-A635-F475B994915B', 'SCHEMA', N'dbo', 'TABLE', N'ADM_SUPPLIER_EMBI', 'COLUMN', N'PHONE_1'
GO
EXEC sp_addextendedproperty N'sys_information_type_name', N'Contact Info', 'SCHEMA', N'dbo', 'TABLE', N'ADM_SUPPLIER_EMBI', 'COLUMN', N'PHONE_1'
GO
EXEC sp_addextendedproperty N'sys_information_type_id', N'5C503E21-22C6-81FA-620B-F369B8EC38D1', 'SCHEMA', N'dbo', 'TABLE', N'ADM_SUPPLIER_EMBI', 'COLUMN', N'PHONE_1'
GO

Even i commit theses changes, they come back every time, like they are not integrated in the git sources referential of like source control see differences.

How can i avoid source control to show differences based on classification metadata between source referential and database ?


Answers

  • @rferraton, it looks like they added the ability to filter out those extended properties in SQL Compare 13.6.14.9174, but that version of the compare engine wasn't incorporated until the 7.0.10.8879 build of SQL Source Control.  If you upgrade to 7.0.10.8879 or above it should respect those settings.  Hope that helps!
  • jamaljamal Posts: 42 Bronze 2
    edited May 10, 2021 3:32PM
    Hi, this is a pretty old thread, but I ran into the same issue for specific extended properties that were not excluded by the standard extended prop. ignore option.  To ignore extended properties sp_addextendedproperty N'sys_sensitivity_label_name' - I found the option by editing the project and checking  "Ignore sensitivity classifications".  Hope this works for you, though I doubt it's still an issue this far out!
    James
Sign In or Register to comment.