Can you help with our Monitor Postgres research? Get involved

Cannot upgrading SQL Monitor getting "Port is not available"

Trying to upgrade SQL Monitor and in the installation options I cannot get past the screen where you click to test the web server port. 

The web server port number is 8080 and when I click on Test I get "Port is not available". However for the monitoring service port number I get "Port is available".

My account is a local administrator on the server. What other permissions does it need for me to complete the installation?

Cheers
Tagged:

Best Answer

  • Alex BAlex B Posts: 971 Diamond 3
    Accepted Answer
    Hi @OrionUK,

    If you currently have SQL Monitor installed and it was installed by another user, then the port may currently be in use by the existing installation - if this is the case, then stopping the current SQL Monitor Webservice or the IIS page will allow you to proceed through the install.  The reason this happens is that the ports are stored in user registry to inform the installer what ports SQL Monitor itself is using, so when the installation is done by a new user, these are not known and the web test will fail.

    If there is another application using port 8080 (i.e. you have not previously had SQL Monitor installed), then you will either need to stop that application that is using the port or use a different port.  You can find out what is using the port by opening an elevated command prompt and executing:
    netstat -aob
    and then looking for what application is using port 8080.

    I hope that helps!

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Answers

  • OrionUKOrionUK Posts: 25 Bronze 1
    Thanks Alex, that would make perfect sense now. I previously used a different account to upgrade but now I have to use a dedicated "admin" account which I had not used before. 

    Stopping SQL Monitor service before I do the upgrade make sense now. 

    Thank you!



Sign In or Register to comment.