How do you use cloud databases? Take the survey.

Cannot upgrading SQL Monitor getting "Port is not available"

Trying to upgrade SQL Monitor and in the installation options I cannot get past the screen where you click to test the web server port. 

The web server port number is 8080 and when I click on Test I get "Port is not available". However for the monitoring service port number I get "Port is available".

My account is a local administrator on the server. What other permissions does it need for me to complete the installation?


Best Answer

  • Alex BAlex B Posts: 1,119 Diamond 4
    Hi @OrionUK,

    If you currently have SQL Monitor installed and it was installed by another user, then the port may currently be in use by the existing installation - if this is the case, then stopping the current SQL Monitor Webservice or the IIS page will allow you to proceed through the install.  The reason this happens is that the ports are stored in user registry to inform the installer what ports SQL Monitor itself is using, so when the installation is done by a new user, these are not known and the web test will fail.

    If there is another application using port 8080 (i.e. you have not previously had SQL Monitor installed), then you will either need to stop that application that is using the port or use a different port.  You can find out what is using the port by opening an elevated command prompt and executing:
    netstat -aob
    and then looking for what application is using port 8080.

    I hope that helps!

    Kind regards,
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • OrionUKOrionUK Posts: 26 Bronze 1
    Thanks Alex, that would make perfect sense now. I previously used a different account to upgrade but now I have to use a dedicated "admin" account which I had not used before. 

    Stopping SQL Monitor service before I do the upgrade make sense now. 

    Thank you!

  • DarrylCDarrylC Posts: 2 New member
    I have this exact same problem. 

    I logged in as the same user as the original install and on the first attempt it actually got past the Port issue and tried to install.  It stopped when it told me that I didn't have privileges to install system services (even though I was logged in as Administrator and ran the installer program "As Administrator").  I had to cancel the install and ended up rebooting the machine to clear out the existing SQL Monitor Web Service as it had been stopped and marked for delete by the installer.  After rebooting, the service no longer appears on the list (though the SQL Monitor service is still running).  I then tried re-running the installer and it came up with the Web server Port in use (8080) issue and the Monitoring service port number passing the test OK. 

    I checked using netstat -aof and nothing is using that port (in fact SQL Monitor is the only external software running on the machine as it was commissioned specifically for it).  It was also originally installed using the recommended Kestrel web server, not IIS so that shouldn't be an issue either. 

    Any help would be much appreciated.
  • OrionUKOrionUK Posts: 26 Bronze 1
    Hi DarrylC, This is issue no longer occurs when I update as the product has been fixed. But what I believe the original issue was that the port was unavailable until I stopped the ipmonitor web service. Then it released port 8080 to allow the upgrade. But over the last year or so I have not had to do this so I assumed this issue was fixed.

  • DarrylCDarrylC Posts: 2 New member
    Thanks OrionUK.  I ended up having to uninstall the Web Monitor altogether (though not the actual SQL Monitor).  This seemed to clear the port  issue and I could then re-install.  Will wait to see if it happens again next time...

Sign In or Register to comment.