Trying to figure out what is taking Commit tab to run for 4-5 minutes. Logs only showing an error

I have updated the LogLevel to All and this is all I get each time I try a commit:

15:47:43.390|WARN   |hared.ObjectExplorer|1  |Object explorer has no nodes, we hooked up in time
15:47:55.468|WARN   |riorityCommandTarget|1  |Unknown command 5efc7975-14bc-11cf-9b2b-00aa00573819 374
System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))
   at EnvDTE.Commands.Item(Object index, Int32 ID)
   at RedGate.SQLSourceControl.CommonUI.VsPriorityCommandTarget.TryGetCommand(Guid commandGuid, UInt32 commandId)

Any suggestions?

Answers

  • duggergduggerg Posts: 5 New member
    I should mention that the process always completes, but I do not receive any additional logs to help me pinpoint any bottlenecks
  • Hi,

    That error has nothing to do with commit taking a while. Would be useful to know:

    - What SOC version are you on?
    - When is it slow? On refresh or on commit
    - What Version control you are connected to?
    - Is the database local? on site? or somewhere further away?
    - If using SVN or TFS? Are they on site or hosted remotely?

    The bottom two are often the cause of slowness, otherwise it would be useful to see the full logs. (Due to a bug they may appear in another Redgate tool's log file). If you don't want to attach the full logs here (very understandable) then you are best getting in touch via [email protected]
    Peter Gerrard

    Software Engineer
    Redgate Software
  • duggergduggerg Posts: 5 New member
    SOC version 7.0.2.8677
    It is slow on refresh
    We are connected to local folder, local folder is using Git to Bitbucket
    SQL 2016 Database is hosted on cloud

    I'm attaching the log file in an email now. We did start getting a more informative log and it is running the refresh a bit faster but maybe we can find some more efficiencies. Thanks! 
Sign In or Register to comment.