Sql Backup Service will not start

ToehoToeho Posts: 73
edited January 23, 2009 3:19PM in SQL Backup Previous Versions
I have a new server running windows 2003 r2 sp2 x64. I have two named instances of sql running sql 2000 x86 (8.00.2187) and sql 2005 x64 (9.00.3228).

I have loaded the red-Gate gui and installed the agents for both instances but the services stay in a starting status. I see 2 SQBCoreService.exe*32 executables running in task manager with 0 cpu and I am unable to make a connection with the Red-Gate gui.

I have verified that both sql instances are up and running and I can make connections to them with the sql tools.

I have uninstalled the server components and used SQBServerSetup.exe to install the server components but the services still stay in a starting state.

Please advise

Thanks,

Comments

  • Eddie DEddie D Posts: 1,733 Rose Gold 5
    Thank you for your post and sorry that you have encountered this problem.

    When the SQL Backup Server components are installed, a registry key is added for each instance which has the path to the SQL Backup Agent executable.

    For a named instance, the path should end with '-i <SQL Instance Name>', for some reason this parameter does not get added to the path and this is what I suspect has occurred.

    Can you please check the following registry key for each SQL Backup Server Components installation to see if it has the '-i <SQL Instance Name>' parameter at the end of the path.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SQLBackupAgent_<InstanceName>

    You should see two folders, one for each instance.

    Locate the ImagePath Key in each folder which is a REG_SZ type, check the data path and ensure that it has the '-i <SQL Instance Name>' parameter at the end of the path.

    If it does not have the '-i <SQL Instance Name>' parameter, please modify the ImagePath key and add the '-i <SQL Instance Name>' parameter to the end of the path.

    Missing the '-i <SQL Instance Name>' parameter:
    C:\Program Files&#40;X86&#41;\Red Gate\&lt;InstanceName&gt;\SQBCoreService.exe
    

    With the '-i <SQL Instance Name>' parameter:
    C:\Program Files&#40;X86&#41;\Red Gate\&lt;InstanceName&gt;\SQBCoreService.exe -i &lt;SQL Instance Name&gt;
    

    You may need to re-boot the server so that the change takes effect.

    I hope that the above advice resolves your problem.

    PLEASE NOTE The above advice only occurs on SQL Servers Instance's that are a named instances. The default or (local) instance do not require the '-i' parameter.

    Many Thanks
    Eddie
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • That was it - Thanks
Sign In or Register to comment.