What are the challenges you face when working across database platforms? Take the survey
Options

SQL Data Compare hangs when closing the comparison key/columns window

This issue occurs on multiple Microsoft OS versions. Current SQL Data Compare Version 13.4.5.6953 Standard.

Issue:

- Open the Comparison Key window

- Close the Comparison Key window (setting a key or not, produces the same result)

Result:

- Application hangs for about 8 seconds, then shows "Not Responding" for about 4 seconds, then becomes functional again.

This is causing issues as it takes a long time to set individual comparison key fields and for some reason the key was not auto mapped between the sources. Any help would be greatly appreciated! Thanks.

Tagged:

Best Answer

  • Options
    Tianjiao_LiTianjiao_Li Posts: 684 Rose Gold 5
    Hi @rbhoule

    Can you confirm if you have the same issue for all your databases?

    SQL Data Compare can automatically map the tables if it can find  a matching primary key or other unique identifier in each data source. Otherwise you'd have to specify customer comparison key manually.
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?

Answers

  • Options
    rbhoulerbhoule Posts: 2 New member
    That explains the reason. I realize now that I am actually comparing a Table to a View even though the names/fields are matching, there is no primary key/unique identifier in that situation. Makes 100% sense in hindsight. Thank you.
  • Options
    Don_VDon_V Posts: 3 New member
    I have this same issue on a thread creating on 01/14/2019. The above solves the issue of not having to open the comparison key or column windows but the underlying issue of it taking 10-30 seconds to "unfreeze" still appears to be in issue in 13.6.x.
  • Options
    Don_VDon_V Posts: 3 New member
    edited November 20, 2019 3:24PM
    This is still an issue as of 11/20/2019 version 14.0.0.12866. It's a brand new project after bringing the change the comparison key dialog OR columns dialog and clicking close (even if I just "X" off it), it takes a good 15-30 seconds to respond (i.e. Not Responding message from windows). 

    *IMPORTANT*
    Unlike the original poster, this is an AUTO mapped table but I'm either changing the comparison to be a non-primary (i.e. composite key) key or not comparing all the columns in the table.
Sign In or Register to comment.