SCA keeps crashing Visual Studio

I recently started getting an error that is crashing VS. Only by disabling SCA am I able to load my project. https://www.screencast.com/t/n4BLnpVoRv4 In order to clear the error, I need to delete the SCA project and recreate it. For various reasons, I do this usually twice a week. I have found SCA to be increasingly unstable since I have been using it in our project. Seems like it is getting worse, not better, with each update. 

Any ideas on what this latest problem is? Thanks. 
Tagged:

Comments

  • Andrea_AngellaAndrea_Angella Cambridge, UK Posts: 66 Silver 3
    I am sorry you are experiencing problems with SCA.

    What version of SCA are you using?
    What version of Visual Studio are you using?

    If you haven't done it already, please get in contact with support and we'll definitely have a look into this.

    Andrea Angella
    Senior Software Engineer | Red Gate
    Website: www.productivecsharp.com
    Twitter: @angella_andrea
  • ducmanducman Posts: 17 Bronze 1
    The same thing happened to me yesterday. Though I'm not sure if the cause is the same for the both of us. VS actually wrote a log of the error in the local temp directory. I was in a rush and decided to delete my git repository and re-clone it down and it work fine after that (I have no changes).
  • Ducman, I'm sorry you're also having issues with SCA. As Andrea suggested, if you contact Redgate support we'll be better equipped to help you fix the problem.
    Mikiel Agutu | Software Engineer | Redgate Software
Sign In or Register to comment.