What are the challenges you face when working across database platforms? Take the survey
Options

Error CommitStaticData

FlorianFlorian Posts: 1 New member
edited June 25, 2018 1:38PM in Source Control for Oracle
Hi!
We started evaluating RedGate's Source Control for Oracle 4.
First results:
  • We started to connect with our git server (running TFS2018) which didn't work.
        -> We are using just a working folder now. (we need git with credential manager / ntlm)
  • We have successfully saved the database schema and objects. 
  • Now we are trying to version some static data into source control. But it actually does not work:

We have created a new table for testing purposes:
SQL for this is:
<br><div><div>CREATE TABLE testredgade (</div><div>&nbsp; id&nbsp; &nbsp; &nbsp; &nbsp;NUMBER&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;NOT NULL,</div><div>&nbsp; vorname&nbsp; VARCHAR2(100 CHAR) NULL,</div><div>&nbsp; nachname VARCHAR2(100 CHAR) NULL,</div><div>&nbsp; wert&nbsp; &nbsp; &nbsp;NUMBER&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;NULL,</div><div>&nbsp; toll&nbsp; &nbsp; &nbsp;VARCHAR2(23 CHAR)&nbsp; NULL</div><div>)</div><div>/</div><div><br></div><div>CREATE UNIQUE INDEX redgate_indx</div><div>&nbsp; ON testredgade (</div><div>&nbsp; &nbsp; id</div><div>&nbsp; )</div><div>/</div><div><br></div><div>ALTER TABLE testredgade</div><div>&nbsp; ADD CONSTRAINT pk_testredgade PRIMARY KEY (</div><div>&nbsp; &nbsp; id</div><div>&nbsp; )</div><div>/</div><div></div></div>
Please don't worry about the redgaDe typo my colleague did. :dizzy: 

That worked fine and changes are tracked in source control.
We added some content to the table:

CONTENT:
ID VORNAME NACHNAME  WERT TOLL  
45 Michael Koepcke   4356 HAHAHA
 1 test1   nachname1    5       
 2 test2   nachname2   67       

We added the table to static data in SCO, refreshed, and then the following happens.



We tried this on two machines, using Win10 and 2008 R2 multiple times. But with no luck.

Any help / solution would be great.


We also had a problem on the windows 10 pc when creating a project based on an existing folder. It didn't finish loading.
At the end, so we were not able to complete the "creation process of a project" using an existing folder.
Tagged:

Best Answer

  • Options
    Alex BAlex B Posts: 1,146 Diamond 4
    Hi All,

    We currently have a private build (version 4.0.11.1079) which corrects this error, please contact support if you are having a similar issue and reference this forum post and that build version.  I'll update here when this has been released into the next full release.

    Kind regards,
    Alex
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Answers

  • Options
    Mike_MMike_M Posts: 1 New member
    Any update on this.  We've run into the same issue.
  • Options
    Eddie DEddie D Posts: 1,792 Rose Gold 5
    Hi,
    Source Control for Oracle V5.0.0.1492 is now available.  This new version includes the fix in private build V4.0.11.1079, to resolve this static data problem.

    Please use either the Check For Updates option within the GUI (Help menu ->Check for Updates) or use this link to download.

    Many Thanks
    Eddie
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: support@red-gate.com
Sign In or Register to comment.