Issue with Microsoft Office Tools

IvanVIvanV Posts: 1 New member
Hi,
We wrote Outlook plug-in and are trying to obfuscate it with SA. We get following error:

SmartAssembly.InformationException: SmartAssembly has encountered an invalid symbol:
[Microsoft.Office.Tools.Outlook.v4.0.Utilities]Microsoft.Office.Tools.Outlook.OutlookAddInBase::.ctor instance System.Void(class [Microsoft.Office.Tools.Outlook]Microsoft.Office.Tools.Outlook.Factory, class [mscorlib]System.IServiceProvider, System.String, System.String)

The most likely cause is that SmartAssembly has used a different version of a dependency from the version used by Qnective.Qtalk.OutlookAddIn.dll. 

If the details below are wrong, please use the MandatoryPath attribute in the .saproj file to ensure that the correct version of the dependency is found.
Assembly that should contain the missing symbol: C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.6.2\Microsoft.Office.Tools.Outlook.v4.0.Utilities.dll


I've tried using MandatoryPath, checked that all versions of stated dll on machine are the same but with same results.
I've also tried setting EmbedInteropTypes on Interop.dll as suggested in similar question on this forum but then project build doesn't output that dll to output folder and then SA  fails with missing this dll.

Could you please suggest remedy for this?

Tagged:

Answers

  • RichardLRichardL Posts: 418 Gold 4
    Hi @IvanV

    Thanks for your post. 

    If you don't receive a timely response here then you could send us a ticket if you have a support contract on your serial key so that a dedicated engineer can investigate your issue. 

    Kind regards

    Richard Lynch. 
    Customer Support
    Redgate Software
Sign In or Register to comment.