Unable to profile a site running under IIS

I am trying to profile a site which is installed on my machine (Windows 10) under IIS.

Right now, I am getting "IIS is not installed on this computer". Attached is the screenshot of the same:

d8e4h78jqv7n.png

The version of the ANTS Memory Profile I am running is 8.12 which is the latest one.

In order to investigate this issue I went to logs folder of ANTS profiler and saw this:

"12 Mar 2018 12:57:49.778 [1] INFO RedGate.Profiler.Logging.LogService - Starting new ANTS Memory Profiler 8 session
12 Mar 2018 12:57:49.787 [1] INFO RedGate.Profiler.Logging.LogService - Assembly version: 8.12.0.246
12 Mar 2018 12:57:54.151 [1] WARN RedGate.Profiler.OS.Local.LocalWindowsVersionInspector - Detected Windows version: Windows 8 (6.2 64-bit)
12 Mar 2018 12:57:54.153 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is not supported on installed OS version."

First of all, I am unable to understand that why ANTS log says that I have "Windows 8". That is wrong, I am running Windows 10 in real.
67aaoqcb7isj.png


I already have .NET 4 installed:
ldu9fn8nho57.png

Can you help me resolve this issue and move forward to profile my application?

IIS is already installed on my computer and I am already running various websites on it. I have already gone through these posts and there is not much help from those.

https://forum.red-gate.com/discussion/82375/memory-profiler-is-closing-my-application
https://forum.red-gate.com/discussion/80437/unable-to-start-profiling-iis-asp-net

Tagged:

Answers

Sign In or Register to comment.