Change Type incorrectly Assigns "New" When actually Should Be "Edit"

jackcrawfishjackcrawfish Posts: 2 New member
edited October 26, 2017 1:32PM in SQL Source Control
Source Control 6 just started to misidentify edits to altered database objects.

If altering a store proc, S.Control ignores the TFS checked in version and treats the "Edit" as "New"

e171w5h2sqtb.jpg

c13o0a4vhc4o.jpg

I've confirmed that the working base directory under the hood is missing the file altogether for an unknown reason. I can confirm the transient version does, in fact, exist.

I've tried unlinking and relinking the database and also tried deletion of the working base directory folder but still am unable to commit anything.

Answers

  • DHack55DHack55 Posts: 1 New member
    I have having this issue as well. I upgraded from 5 to 6 and it started happening. I even deleted all my SC 5 folder in AppData and still am getting news when it should be edits.
  • way0utwestway0utwest CO, USA Posts: 303 Rose Gold 1
    Is this the same object or all objects or a type of object (all procs)? I haven't seen this, but sometimes the Compare engine will find an inconsistent state that it can't resolve.

    SQL Source Control essentially manages a SQL Compare execution between your database and your VCS. Did the object get changed in the VCS outside of SSMS/SQL Source Control?
Sign In or Register to comment.