How can I fix VSTS ReadyRoll CI Build Error "Imported Project Not Found"?

When performing a CI build on VSTS I get the following error:
The imported project "C:\Program Files (x86)\MSBuild\ReadyRoll\ReadyRoll.Data.Schema.SSDT.targets" was not found.

I have tried amending it to be where the correct location now is as per workarounds found online but I still get the error above.
<ReadyRollTargetsPath>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\ReadyRoll\ReadyRoll.Data.Schema.SSDT.targets</ReadyRollTargetsPath>
This path and file definitely exists on my machine.

It still gets the error above though as it doesn't think this path exists. I've tried a number of different varieties of hard-coding and folder path names but can't seem to fix it.

Can someone please help?

Best Answer

  • griff182ukgriff182uk Posts: 9 New member
    Accepted Answer
    Apologies to anyone who tried to find answer for this. I was being stupid...

    All I had to do was change the CI build to be using agent "Hosted VS 2017" instead of just "Hosted".

    Doh!
Sign In or Register to comment.