The list of changes is out of date. TF10141: ...resolve the conflicts an try again

I'm using SQL Source Control v5.7.6.6321, connected to TFS online, and using a dedicated database for development.

I'm stuck trying to commit some changes involving 2 new columns in 2 tables, with adjusted stored procedure crud to match. My commit fails on the step "Sending files to source control server" with the following message;
"The list of changes to commit is out of date. To update the list, in the Commit tab, click Refresh."

If I then click the associated hyperlink, the following TFS error is displayed;
"TF10141: No files checked in: resolve the conflicts and try again."

What I have done so far;
- gone to the commit tab and clicked Refresh, as suggested.
- restarted SSMS
- restarted PC
- scripted out changes. Rolled back all changes. Confirmed nothing to get or commit. Re-applied changes. Same error.
- used SQL Compare on local dev db against source control to see if something is hiding. To me, the generated script is exactly the changes I'm trying to apply, and nothing stands out as an issue.

The Source Control UI never reports any sort conflict for me to resolve.
It's as though something is out of sync somewhere, but I'm not sure where to look next.
Tagged:

Answers

  • TickDoneTickDone Posts: 2 New member
    I solved the problem using the following workaround.

    1. On first PC - Run SQL compare: source = local dev database, target = source control
    2. Save script and transfer to second PC (I did not roll back changes on the first PC)
    3. On the second PC, Get latest database version from source control
    4. Apply script to local DB on the second PC
    5. Check in changes
    6. Return to the first PC, get latest -- all changes now up to date
  • I'm glad you managed to resolve it. Another way to deal with the problem would be to unlink and relink your database to source control - that should reset all cached information.
    Development Lead
    Redgate Software
  • MartinKellyMartinKelly Posts: 1 New member
    Re-linking worked for me
Sign In or Register to comment.