What are the challenges you face when working across database platforms? Take the survey
Options

Black dialogue on installation under alternative credentials

I typically run SSMS via a shortcut configured with RunAs a personal account with higher network privileges than my standard login, and the NetOnly switch. The credentials for that account are also those I typically use when presented with an ACL prompt for installing any software or making changes that require local Admin permissions.

Attempting to install a newer version of SQL Prompt via such an SSMS session prompts for admin credentials (so I use the ones mentioned above) then presents me with a blacked out installation dialogue box. Makes it a bit hard to see what I'm being asked and where the buttons are.

Now, I can work around this by hitting Escape (to close the blacked out dialogue), closing SSMS, re-opening under my standard credentials etc but it would be far more convenient to just be able to install it via my usual environment. Is this reproducible by others? If so, is this (admittedly minor) annoyance likely to be looked into by Red-Gate?

FURTHER DETAIL
Shortcut Target: C:\Windows\System32\runas.exe /user:DOMAIN\USERNAME /netonly "C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\Ssms.exe -nosplash"

SSMS client 2014
Windows 10 Enterprise Version 1607 (I'm fairly sure I had the same issue in a previous version too)

Comments

  • Options
    Hi @ColinFF,

    I tried to reproduce your problem, but I couldn't. Does this happen also with new installer?
    xg36h5ib404s.png

    Best regards,
    Krzysztof
  • Options
    ColinFFColinFF Posts: 2 New member
    New installer not working either - but this time I don't even get the window. Hovering over the task bar icon gives this:
    dzndhr2ak66z.png

    Shift-Right click (to see if I can get an option to move the window) gives this:
    xrkt7ri91y4e.png

    Tried a couple of other things to get the window to come to the fore, such as cascading windows, but it did not appear.

    Right click gives this:
    hkxppl7bypuw.png

    So no joy yet.
Sign In or Register to comment.