SmartAssembly integration with MSBuild produces hexadecimal value 0x01, an invalid character

I'm trying to follow these instructions:

https://documentation.red-gate.com/display/SA6/Using+SmartAssembly+with+MSBuild

When the SmartAssembly task executes, I get this error, and I have no idea how to correct it.

SmartAssembly v6.9.0.114
Copyright © Red Gate Software 2005–2014
Loading project D:\B\9\Sources\Source\Eaton.Vcp.SmartAssembly\EatonVcp6.saproj
Input=D:\B\9\Binaries\Release\EatonVcp6.exe
Output=D:\B\9\Binaries\Release\EatonVcp6.exe
Loading...
Starting...
Analyzing...
Preparing...
Creating assembly...
OK
vbc : warning BC40010: Possible problem detected while building assembly 'EatonVcpDataEditor': Referenced assembly 'mscorlib.dll' targets a different processor [D:\B\9\Sources\Source\Eaton.Vcp.DataEditor\Eaton.Vcp.DataEditor.vbproj]
vbc : warning BC40010: Possible problem detected while building assembly 'EatonVcpDataEditor': Referenced assembly 'System.Data.dll' targets a different processor [D:\B\9\Sources\Source\Eaton.Vcp.DataEditor\Eaton.Vcp.DataEditor.vbproj]
Eaton.Vcp.DataEditor -> D:\B\9\Binaries\Release\EatonVcpDataEditor.exe
vbc : warning BC40010: Possible problem detected while building assembly 'EatonVcpSettingsEditor': Referenced assembly 'mscorlib.dll' targets a different processor [D:\B\9\Sources\Source\Eaton.Vcp.SettingsEditor\Eaton.Vcp.SettingsEditor.vbproj]
vbc : warning BC40010: Possible problem detected while building assembly 'EatonVcpSettingsEditor': Referenced assembly 'System.Data.dll' targets a different processor [D:\B\9\Sources\Source\Eaton.Vcp.SettingsEditor\Eaton.Vcp.SettingsEditor.vbproj]
Eaton.Vcp.SettingsEditor -> D:\B\9\Binaries\Release\EatonVcpSettingsEditor.exe
Eaton.Vcp.RP1210IniFile -> D:\B\9\Binaries\Release\Eaton.Vcp.RP1210IniFile.dll
Analyzing labels Vcp_CurrentDB_6.2.1.1057 and Vcp_CurrentDB_6.2.1.1058.
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5,1784,5): error : '', hexadecimal value 0x01, is an invalid character. [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: The "GetImpactedTests" task failed unexpectedly. [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: System.ArgumentException: '', hexadecimal value 0x01, is an invalid character. [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at System.Activities.WorkflowApplication.Invoke(Activity activity, IDictionary`2 inputs, WorkflowInstanceExtensionManager extensions, TimeSpan timeout) [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at System.Activities.WorkflowInvoker.Invoke(Activity workflow, IDictionary`2 inputs, TimeSpan timeout, WorkflowInstanceExtensionManager extensions) [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at Microsoft.TeamFoundation.Build.Tasks.WorkflowTask.ExecuteInternal() [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at Microsoft.TeamFoundation.Build.Tasks.Task.Execute() [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute() [D:\B\9\BuildType\TFSBuild.proj]
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\TeamBuild\Microsoft.TeamFoundation.Build.targets(1784,5): error MSB4018: at Microsoft.Build.BackEnd.TaskBuilder.ExecuteInstantiatedTask(ITaskExecutionHost taskExecutionHost, TaskLoggingContext taskLoggingContext, TaskHost taskHost, ItemBucket bucket, TaskExecutionMode howToExecuteTask, Boolean& taskResult) [D:\B\9\BuildType\TFSBuild.proj]

Everything builds correctly and runs successfully if I go through the SmartAssembly user interface.

Comments

  • mlshoe63mlshoe63 Posts: 4 New member
    This turned out to be due to post-processing of an obfuscated build (for unit testing), which is of course not supported. I now have two builds: one for unit testing, and one for obfuscation.
Sign In or Register to comment.