The latest stable build of SQL Prompt is 8.2.3.2750 (18th October)

James RJames R Posts: 104 Silver 3
edited October 25, 2017 9:20AM in SQL Prompt
Download

What's new?

This build of SQL Prompt includes these improvements:
  • SP-6651 : Fix truncate table statement formatting

See the full release notes for full details

Feedback

If you find any issues with this release, please post them on this forum.

If you have any suggestions for improvements, please post them on our suggestions forum so other users can vote for them.
Software Engineer
Redgate Software
Tagged:

Comments

  • Thanks James, I will try it. I need improve my old database ;D
    Magarita
    Regalos bebe
  • I just updated to SQL Prompt 8.1. Is anyone else experiencing Ctrl+K, Ctrl+Y (Format SQL) not working in Visual Studio 2017? I'm running VS 2017 v15.3.5. I've assigned the shortcut in VS options as well, but it's still not working. No issues in SSMS.

    Thanks,
    Jason
  • Updated to 8.2 but the SQLPrompt menu went away and Tab History went away. I'm using SSMS 14.0.17177.0 and SSMS 13.0.16106.4. Intellisense is not working at all. I reran the installer but it says it's already installed and current. I rolled back to 8.0 and everything is working as expected again - intellisense is working, SQLPrompt menu is back and Tab History tab is back. I updated to 8.2 again with the same result.
  • DWJenkinsDWJenkins Posts: 4 New member
    I got a pop-up this morning saying to install 8.2. Done and I also have lost prompt in the menus, intellisense. I'm using SSMS 17.2.
  • Hey guys,

    Thanks for letting us know about this issue. We've taken down the release for now to investigate, hopefully will have a fix soon. In the meantime, if you uninstall SQL Prompt 8.1 and then download SQL Prompt 8.2 from the website the update should work correctly.

    Sorry for the inconvenience!
    James
    Software Engineer
    Redgate Software
  • Hey @AstoundingJam18 and @DWJenkins ,

    We've just released a new build of SQL Prompt which should have fixed this issue. Thanks again for letting us know! Please update and let me know that the issue is fixed.

    Regards,
    James
    Software Engineer
    Redgate Software
  • Just upgraded and Intellisense does not work. Tab history is present. I had to put my license details back in as it changed it to a trial version
  • MikeM244MikeM244 Posts: 1 New member
    Had the same issue as others had posted. Install version 8.2.0.2509 and everything is back and working correctly and I didn't have re-enter my license info.
  • Installed 8.2 again and it's working now. Thanks for the prompt fix!
  • GregDoddGregDodd Posts: 6 Bronze 1
    I'm get errors on formatting delete and update statements. E.g. for this script:
    CREATE TABLE #TempTable (col1 INT)
    
    
    DELETE Stock
    FROM #TempTable
    INNER JOIN Stock
    ON Stock.stockid= col1
    WHERE Stock.BaseQuantity = 10
    

    I get a message: y35sduvx9gq4.png

    When I look at the error, I see this:
    kqrtqww4yx3p.png

  • BeegeBeege Posts: 2 New member
    edited October 6, 2017 4:38PM
    I'm experiencing the same as @GregDodd with an update statement using a temp table and inner join also. It highlights the first letter of the statement with the same message of "Value cannot be null."

    Using SQL Prompt v8.2.1.2603 in SSMS 13.0.16106.4
  • jackcrawfishjackcrawfish Posts: 2 New member
    edited October 6, 2017 2:49AM
    I have similar issue laying out SQL... Ctrl K + Y

    It "throws up" on me and always draws me to semi-colons.

    When looking at my Default Setings, I noticed a "." at the end of the example.

    6avwbj76n7j3.jpg
    g0yks7n5dm9o.png

    ssms details:

    Microsoft SQL Server Management Studio 12.0.4100.1
    Microsoft Analysis Services Client Tools 12.0.4100.1
    Microsoft Data Access Components (MDAC) 6.1.7601.17514
    Microsoft MSXML 3.0 4.0 6.0
    Microsoft Internet Explorer 9.11.9600.18792
    Microsoft .NET Framework 4.0.30319.42000
    Operating System 6.1.7601
  • FredericoJFredericoJ Posts: 31 Bronze 2
    edited October 6, 2017 9:27AM
    Hi @GregDodd, @Beege and @jackcrawfish,

    Apologies for the issues you are seeing and thank you for reporting the problem.

    We've tried to replicate the issue locally but so far we've been unable to.

    Would it be possible for you to send us the formatting style (either on the forums or by emailing it to us at sqlpromptteam@red-gate.com) that is throwing up the problem (e.g. Limit LINES)?

    Thanks,

    Frederico
    Software Engineer
    Redgate Software
  • BeegeBeege Posts: 2 New member
    I just sent the email to you with the style, screenshot, and sample code. Hope that helps! Thanks so much for looking into this!
  • GregDoddGregDodd Posts: 6 Bronze 1
    Style sent via email
  • Hi @Beege and @GregDodd,

    Thank you for sending us your styles and example code.

    We've now been able to reproduce the problem and are currently working on a fix.

    We'll let you know as soon as it's available.

    Kind regards,

    Frederico
    Software Engineer
    Redgate Software
  • In the mean time, is there a work around?
  • krzysztofkroczakkrzysztofkroczak Posts: 38 Silver 1
    edited October 11, 2017 10:43AM
    Hi @EnrightMcC, @Beege, @GregDodd, @jackcrawfish,

    We released today a new version with fix: 8.2.2.2657

    Best regards,
    Krzysztof
  • eugeneneugenen Posts: 6 Bronze 1
    edited October 20, 2017 12:46PM
    I've lost the menu too and when I run the installer as an administrator it says its forbidden by a system policy
Sign In or Register to comment.