What are the challenges you face when working across database platforms? Take the survey
Options

Why my WPF application is not responding?

Dil3RDil3R Posts: 2 New member
edited September 13, 2017 8:03AM in SmartAssembly
Hello,
I have created WPF modular application using PRISM. It works on .NET 4.5.2.
With SmartAssembly 6.6 I have successfully created many executable files with different project configurations. But the problem is that all of them works the same. After run my application is not responding for long time (about minute or more). After that time initial view finally loads, and everything works perfectly. I don't have that problem when I run raw file generated by Visual studio. I tried another obfuscator and the file he generated is executed without any delay just like input file. I have read that newer versions of SmartAssembly added suppoer for .NET 4.5.2 and improved working with WPF projects. Please tell me if that may be the cause and if not what should I do to solve this problem.

Edit:
I have upgraded my SmartAssembly version to 6.9, but it didn't help at all. In Error Reports informs me that executing application throws RegionCreationExceptions.
Sign In or Register to comment.